On Sat, Jan 04, 2020 at 11:02:01AM +0000, atmgnd wrote: > accroding to bd0e6c9#diff-28615d62e1250eadc353d804f49bc6d6, will try old enumeration > scheme first for high speed devices. for example, when a high speed device pluged in, > line 2720 should expand to 0 at the first time. USE_NEW_SCHEME(0, 0 || 0 || 1) === 0. > but it wrongly expand to 1(alway expand to 1 for high speed device), and change > USE_NEW_SCHEME to USE_NEW_SCHEME((i) % 2 == (int)(scheme)) may be better ? > > Acked-by: Alan Stern <stern@xxxxxxxxxxxxxxxxxxx> > Signed-off-by: Qi Zhou <atmgnd@xxxxxxxxxxx> > --- > drivers/usb/core/hub.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/drivers/usb/core/hub.c b/drivers/usb/core/hub.c > index f229ad6952c0..7d17deca7021 100644 > --- a/drivers/usb/core/hub.c > +++ b/drivers/usb/core/hub.c > @@ -2692,7 +2692,7 @@ static unsigned hub_is_wusb(struct usb_hub *hub) > #define SET_ADDRESS_TRIES 2 > #define GET_DESCRIPTOR_TRIES 2 > #define SET_CONFIG_TRIES (2 * (use_both_schemes + 1)) > -#define USE_NEW_SCHEME(i, scheme) ((i) / 2 == (int)scheme) > +#define USE_NEW_SCHEME(i, scheme) ((i) / 2 == (int)(scheme)) > > #define HUB_ROOT_RESET_TIME 60 /* times are in msec */ > #define HUB_SHORT_RESET_TIME 10 > -- > 2.17.1 > > Much better, but your From: name does not match your signed-off-by name :(