Re: [PATCH] Add nuvoton Ehci driver to usb tree

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



> +#include <linux/platform_device.h>
> +
> +/*ebable phy0 and phy1 for w90p910*/
> +#define        ENPHY   (0x01<<8)
> +
> +int usb_w90x900_probe(const struct hc_driver *driver,
> +                     struct platform_device *pdev)

You may want to use 'static' for this? As well as the '*_remove'
one below.

> +{
> +       struct usb_hcd *hcd;
> +       struct ehci_hcd *ehci;
> +       int retval;
> +
> +       if (pdev->resource[1].flags != IORESOURCE_IRQ) {
> +               pr_debug("resource[1] is not IORESOURCE_IRQ");
> +               retval = -ENOMEM;
> +       }
> +

wouldn't platform_get_irq() much cleaner for this, with the IRQ
returned, and no restriction of the order of resources?

> +       hcd = usb_create_hcd(driver, &pdev->dev, "w90x900 EHCI");
> +       if (!hcd) {
> +               retval = -ENOMEM;
> +               goto err1;
> +       }
> +
> +       hcd->rsrc_start = pdev->resource[0].start;
> +       hcd->rsrc_len = pdev->resource[0].end - pdev->resource[0].start + 1;
> +
> +       if (!request_mem_region(hcd->rsrc_start, hcd->rsrc_len, hcd_name)) {
> +               pr_debug("request_mem_region failed");

dev_dbg() and friends might be better for this, and the other printk
occurrences below.

> +               retval = -EBUSY;
> +               goto err2;
> +       }
> +
> +       hcd->regs = ioremap(hcd->rsrc_start, hcd->rsrc_len);
> +       if (hcd->regs == NULL) {
> +               pr_debug("error mapping memory\n");
> +               retval = -EFAULT;
> +               goto err3;
> +       }
> +
> +       ehci = hcd_to_ehci(hcd);
> +       ehci->caps = hcd->regs;
> +       ehci->regs = hcd->regs +
> +                HC_LENGTH(ehci_readl(ehci, &ehci->caps->hc_capbase));
> +
> +       /* enable PHY 0,1,the regs only apply to w90p910
> +       *  0xA4,0xA8 were offsets of PHY0 and PHY1 controller of
> +       *  w90p910 IC relative to ehci->regs.
> +       */
> +       __raw_writel(__raw_readl(ehci->regs+0xA4)|ENPHY, ehci->regs+0xA4);
> +       __raw_writel(__raw_readl(ehci->regs+0xA8)|ENPHY, ehci->regs+0xA8);
> +

This is ... ugh ... a bit ugly:

        v = __raw_readl(ehci->regs + PHY0_CONTROL) | ENPHY;
        __raw_writel(v, ehci->regs + PHY0_CONTROL);

looks better? And note the magic number of 0xa4, 0xa8, just
give'em good names.

> +       ehci->hcs_params = ehci_readl(ehci, &ehci->caps->hcs_params);
> +       ehci->sbrn = 0x20;
> +
> +       retval = usb_add_hcd(hcd, pdev->resource[1].start, IRQF_SHARED);
> +       if (retval != 0)
> +               goto err4;
> +
> +       ehci_writel(ehci, 1, &ehci->regs->configured_flag);
> +
> +       return retval;
> +err4:
> +       iounmap(hcd->regs);
> +err3:
> +       release_mem_region(hcd->rsrc_start, hcd->rsrc_len);
> +err2:
> +       usb_put_hcd(hcd);
> +err1:
> +       return retval;
> +}
> +
> +void usb_w90x900_remove(struct usb_hcd *hcd, struct platform_device *pdev)
> +{
> +       usb_remove_hcd(hcd);
> +       iounmap(hcd->regs);
> +       release_mem_region(hcd->rsrc_start, hcd->rsrc_len);
> +       usb_put_hcd(hcd);
> +}
> +
> +static const struct hc_driver ehci_w90x900_hc_driver = {
> +       .description = hcd_name,
> +       .product_desc = "Nuvoton w90x900 EHCI Host Controller",
> +       .hcd_priv_size = sizeof(struct ehci_hcd),
> +
> +       /*
> +        * generic hardware linkage
> +        */
> +       .irq = ehci_irq,
> +       .flags = HCD_USB2|HCD_MEMORY,
> +
> +       /*
> +        * basic lifecycle operations
> +        */
> +       .reset = ehci_init,
> +       .start = ehci_run,
> +
> +       .stop = ehci_stop,
> +       .shutdown = ehci_shutdown,
> +
> +       /*
> +        * managing i/o requests and associated device resources
> +        */
> +       .urb_enqueue = ehci_urb_enqueue,
> +       .urb_dequeue = ehci_urb_dequeue,
> +       .endpoint_disable = ehci_endpoint_disable,
> +
> +       /*
> +        * scheduling support
> +        */
> +       .get_frame_number = ehci_get_frame,
> +
> +       /*
> +        * root hub support
> +        */
> +       .hub_status_data = ehci_hub_status_data,
> +       .hub_control = ehci_hub_control,
> +#ifdef CONFIG_PM
> +       .bus_suspend = ehci_bus_suspend,
> +       .bus_resume = ehci_bus_resume,
> +#endif
> +       .relinquish_port        = ehci_relinquish_port,
> +       .port_handed_over       = ehci_port_handed_over,
> +};
> +
> +static int ehci_w90x900_probe(struct platform_device *pdev)

__devinit? And actually hc_driver->probe() can be well integrated
into this _probe() like the way ehci-orion.c is doing, that will be
much nature, I'm not sure the common practice here, though.

> +{
> +       if (usb_disabled())
> +               return -ENODEV;
> +
> +       return usb_w90x900_probe(&ehci_w90x900_hc_driver, pdev);
> +}
> +
> +static int ehci_w90x900_remove(struct platform_device *pdev)

__devexit

> +{
> +       struct usb_hcd *hcd = platform_get_drvdata(pdev);
> +
> +       usb_w90x900_remove(hcd, pdev);
> +
> +       return 0;
> +}
> +
> +static struct platform_driver ehci_hcd_w90x900_driver = {
> +       .probe  = ehci_w90x900_probe,
> +       .remove = ehci_w90x900_remove,

__devexit_p()

> +       .driver = {
> +               .name = "w90x900-ehci",
> +               .owner = THIS_MODULE,
> +       },
> +};
> +
> +MODULE_AUTHOR("Wan ZongShun <mcuos.com@xxxxxxxxx>");
> +MODULE_DESCRIPTION("w90p910 usb ehci driver!");
> +MODULE_LICENSE("GPL");
> +MODULE_ALIAS("w90x900-ehci");

"platform:w90x900-ehci"
--
To unsubscribe from this list: send the line "unsubscribe linux-usb" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html

[Index of Archives]     [Linux Media]     [Linux Input]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]     [Old Linux USB Devel Archive]

  Powered by Linux