On Thu, 4 Jul 2019, Ryan Kennedy wrote: > usb_amd_find_chipset_info() is used for chipset detection for > several quirks. It is strange that its return value indicates > the need for the PLL quirk, which means it is often ignored. > This patch adds a function specifically for checking the PLL > quirk like the other ones. Additionally, rename probe_result to > something more appropriate. > > Signed-off-by: Ryan Kennedy <ryan5544@xxxxxxxxx> > @@ -322,6 +317,13 @@ bool usb_amd_prefetch_quirk(void) > } > EXPORT_SYMBOL_GPL(usb_amd_prefetch_quirk); > > +bool usb_amd_quirk_pll_check(void) > +{ > + usb_amd_find_chipset_info(); > + return amd_chipset.need_pll_quirk; > +} > +EXPORT_SYMBOL_GPL(usb_amd_quirk_pll_check); I really don't see the point of separating out all but one line into a different function. You might as well just rename usb_amd_find_chipset_info to usb_amd_quirk_pll_check (along with the other code adjustments) and be done with it. However, in the end I don't care if you still want to do this. Either way: Acked-by: Alan Stern <stern@xxxxxxxxxxxxxxxxxxx> Alan Stern