Use USB_DIR_IN instead of 1 when calling musb_advance_schedule(). This is consistent with the rest of musb_host.c code and impoves the readability. Signed-off-by: Matwey V. Kornilov <matwey@xxxxxxxxxx> --- drivers/usb/musb/musb_host.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/usb/musb/musb_host.c b/drivers/usb/musb/musb_host.c index eb308ec35c66..3ffea6a5e022 100644 --- a/drivers/usb/musb/musb_host.c +++ b/drivers/usb/musb/musb_host.c @@ -1195,7 +1195,7 @@ irqreturn_t musb_h_ep0_irq(struct musb *musb) /* call completion handler if done */ if (complete) - musb_advance_schedule(musb, urb, hw_ep, 1); + musb_advance_schedule(musb, urb, hw_ep, USB_DIR_IN); done: return retval; } -- 2.16.4