Hi, This is the third version of my proposal to add device graph parsing to the device connection API. There was only one problem reported in v2 by Jun - kernel-doc entry was missing for the new fwnode member in struct usb_role_switch_desc - and it's now fixed. The second version of the series: https://lkml.org/lkml/2019/1/30/622 The commit message from v1: This series adds support for OF and ACPI device graph parsing to the device connection API. Handling the graph is straightforward, but because I'm adding that fwnode member to struct device_connection, I had to make sure all the existing users consider it. The plan is to only support matching with fwnode in the future, so no more device name matching. The software fwnodes that we now have in kernel should make that possible, once we add support for references to them. The original RFC: https://lkml.org/lkml/2018/10/24/619 thanks, Heikki Krogerus (9): platform/x86: intel_cht_int33fe: Prepare for better mux naming scheme usb: typec: Rationalize the API for the muxes platform/x86: intel_cht_int33fe: Remove old style mux connections device connection: Add fwnode member to struct device_connection usb: typec: mux: Find the muxes by also matching against the device node usb: roles: Find the muxes by also matching against the device node usb: typec: Find the ports by also matching against the device node device connection: Prepare support for firmware described connections device connection: Find device connections also from device graphs drivers/base/devcon.c | 62 ++++++++++++++- drivers/platform/x86/intel_cht_int33fe.c | 15 ++-- drivers/usb/roles/class.c | 21 +++++- drivers/usb/typec/class.c | 31 ++++++-- drivers/usb/typec/mux.c | 96 ++++++++++++++++++++---- include/linux/device.h | 6 ++ include/linux/usb/role.h | 2 + include/linux/usb/typec_mux.h | 3 +- 8 files changed, 196 insertions(+), 40 deletions(-) -- 2.20.1