Hi Bin, On Thursday, 11 October 2018 19:10:21 EEST Bin Liu wrote: > On Tue, Oct 09, 2018 at 10:49:01PM -0400, Paul Elder wrote: > > A usb gadget function driver may or may not want to delay the status > > stage of a control OUT request. An instance it might want to is to > > asynchronously validate the data of a class-specific request. > > > > Add a function usb_ep_delay_status to allow function drivers to choose > > to delay the status stage in the request completion handler. The UDC > > should then check the usb_ep->delayed_status flag and act accordingly to > > delay the status stage. > > > > Also add a function usb_ep_send_response as a wrapper for > > usb_ep->ops->send_response, whose prototype is added as well. This > > function should be called by function drivers to tell the UDC what to > > reply in the status stage that it has requested to be delayed. > > > > Signed-off-by: Paul Elder <paul.elder@xxxxxxxxxxxxxxxx> > > Reviewed-by: Laurent Pinchart <laurent.pinchart@xxxxxxxxxxxxxxxx> > > --- > > > > drivers/usb/gadget/udc/core.c | 35 +++++++++++++++++++++++++++++++++++ > > include/linux/usb/gadget.h | 11 +++++++++++ > > 2 files changed, 46 insertions(+) > > > > diff --git a/drivers/usb/gadget/udc/core.c b/drivers/usb/gadget/udc/core.c > > index af88b48c1cea..1ec5ce6b43cd 100644 > > --- a/drivers/usb/gadget/udc/core.c > > +++ b/drivers/usb/gadget/udc/core.c > > @@ -443,6 +443,41 @@ void usb_ep_fifo_flush(struct usb_ep *ep) > > } > > EXPORT_SYMBOL_GPL(usb_ep_fifo_flush); > > > > +/** > > + * usb_ep_ep_delay_status - set delay_status flag > > + * @ep: the endpoint whose delay_status flag is being set > > + * > > + * This function instructs the UDC to delay the status stage of a control > > + * request. It can only be called from the request completion handler of > > a > > + * control request. > > + */ > > +void usb_ep_delay_status(struct usb_ep *ep) > > +{ > > + ep->delayed_status = true; > > +} > > +EXPORT_SYMBOL_GPL(usb_ep_delay_status); > > Is usb_ep_set_delay_status() better? I thought it implies get/return > action if a verb is missing in the function name. For what it's worth, I understand the function name as "delay the status stage", with "delay" being a verb. Maybe the short description could be updated accordingly. -- Regards, Laurent Pinchart