Sarah Sharp wrote: > > +static int usb_parse_endpoint_companion(struct device *ddev, int cfgno, > + int inum, int asnum, struct usb_host_endpoint *ep, > + int num_ep, unsigned char *buffer, int size) This should be called usb_parse_superspeed_endpoint_companion() or similar. To avoid confusion with other types of endpoint companion descriptors (e.g., the wireless endpoint companion as used in Wireless USB). > +/* USB_DT_SS_ENDPOINT_COMP: SuperSpeed Endpoint Companion descriptor */ > +struct usb_ep_comp_descriptor { > + __u8 bLength; > + __u8 bDescriptorType; > + > + __u8 bMaxBurst; > + __u8 bmAttributes; > + __u16 wBytesPerInterval; > +} __attribute__ ((packed)); struct usb_ss_ep_comp_descriptor > + > +#define USB_DT_EP_COMP_SIZE 6 #define USB_DT_SS_ENDPOINT_COMP_SIZE There may be other structures or functions that should be renamed. David -- David Vrabel, Senior Software Engineer, Drivers CSR, Churchill House, Cambridge Business Park, Tel: +44 (0)1223 692562 Cowley Road, Cambridge, CB4 0WZ http://www.csr.com/ -- To unsubscribe from this list: send the line "unsubscribe linux-usb" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html