Re: [PATCH] usb: Replace empty define with do while

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Thu, 2018-06-07 at 20:05 +0000, Corentin Labbe wrote:
> It's dangerous to use empty code define.
> Furthermore it lead to the following warning:
> "suggest braces around empty body in an « else » statement"
> 
> So let's replace emptyness by "do {} while(0)"

I also suggest renaming COUNT to something more
intelligible like INCR as the uses are all for
incrementing variables that may not exist.

> diff --git a/drivers/usb/host/ehci.h b/drivers/usb/host/ehci.h
> index c8e9a48e1d51..a60d91eac771 100644
> --- a/drivers/usb/host/ehci.h
> +++ b/drivers/usb/host/ehci.h
> @@ -237,7 +237,7 @@ struct ehci_hcd {			/* one per controller */
>  	struct ehci_stats	stats;
>  #	define COUNT(x) ((x)++)
>  #else
> -#	define COUNT(x)
> +#	define COUNT(x) do {} while (0)
>  #endif
>  
>  	/* debug files */
> diff --git a/drivers/usb/host/fotg210.h b/drivers/usb/host/fotg210.h
> index 7fcd785c7bc8..dca46d04e288 100644
> --- a/drivers/usb/host/fotg210.h
> +++ b/drivers/usb/host/fotg210.h
> @@ -179,7 +179,7 @@ struct fotg210_hcd {			/* one per controller */
>  	struct fotg210_stats	stats;
>  #	define COUNT(x) ((x)++)
>  #else
> -#	define COUNT(x)
> +#	define COUNT(x) do {} while (0)
>  #endif
>  
>  	/* debug files */
--
To unsubscribe from this list: send the line "unsubscribe linux-usb" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html



[Index of Archives]     [Linux Media]     [Linux Input]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]     [Old Linux USB Devel Archive]

  Powered by Linux