Am Mittwoch, den 13.12.2017, 14:31 +0300 schrieb Mikhail Zaytsev: > On Wed, 13 Dec 2017 11:17:28 +0100 Oliver Neukum <oneukum@xxxxxxxx> wrote: > > > > > Am Mittwoch, den 13.12.2017, 12:30 +0300 schrieb Mikhail Zaytsev: > > > > > > +#define RS232_VENDOR 0x6547 > > > +#define RS232_PRODUCT 0x0232 > > > +#define IRDA_VENDOR 0x18ec > > > +#define IRDA_PRODUCT 0x3118 > > > > > > /* usb timeout of 1 second */ > > > #define ARK_TIMEOUT 1000 > > > > > > static const struct usb_device_id id_table[] = { > > > - { USB_DEVICE(0x6547, 0x0232) }, > > > - { USB_DEVICE(0x18ec, 0x3118) }, /* USB to IrDA adapter */ > > > + { USB_DEVICE(RS232_VENDOR, RS232_PRODUCT) }, > > > + { USB_DEVICE(IRDA_VENDOR, IRDA_PRODUCT) }, /* USB to IrDA adapter */ > > > > Hi, > > > > what is the purpose of this change? It just makes it harder to grep. > > The constants are arbitrary and they are clearly device IDs. > > The constants are using in several places. > I think the names easier to read. They give you nothing. If you are looking at a vendor ID nothing but the bare number makes sense. You are just making peoples' life harder when they have to look up that definition. A symbolic name is fine if it gives meaning. Even if the information you give is that the value is magic and therefore not understood. But a vendor ID is an arbitrary yet meaningful number. There is no point in hiding it. Regards Oliver -- To unsubscribe from this list: send the line "unsubscribe linux-usb" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html