Re: [PATCH] gadget event trace : add request pointer

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hi,

Matthieu CASTET <matthieu.castet@xxxxxxxxxx> writes:
> This allow to identify transfert request, if more than one are in queue.
       ^^^^^             ^^^^^^^^^
       allows            transfer

> @@ -238,9 +239,10 @@ DECLARE_EVENT_CLASS(udc_log_req,
>  		__entry->short_not_ok = req->short_not_ok;
>  		__entry->status = req->status;
>  		__entry->ret = ret;
> +		__entry->req = req;
>  	),
> -	TP_printk("%s: length %d/%d sgs %d/%d stream %d %s%s%s status %d --> %d",
> -		__get_str(name), __entry->actual, __entry->length,
> +	TP_printk("%s: req[%p] length %d/%d sgs %d/%d stream %d %s%s%s status %d --> %d",

This is, indeed, really useful. However do you mind removing the [] and
adding a space so that output looks like:

[00:59:36.784082]      ->transport-222   [002] d..1   112.602331: usb_ep_queue: ep1in: req ffffffc07c234710 length 0/7 sgs 0/0 stream 0 zsI status -115 --> 0

IMHO it's a little easier to read and matches the format we already have
on dwc3 (not that it matters, it'd just be easier to write a parser :-)

cheers

-- 
balbi

Attachment: signature.asc
Description: PGP signature


[Index of Archives]     [Linux Media]     [Linux Input]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]     [Old Linux USB Devel Archive]

  Powered by Linux