Re: [PATCH] USB: serial: pl2303: add new ATEN device id

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Wed, Aug 09, 2017 at 10:28:00AM +0200, Johan Hovold wrote:
> On Tue, Aug 08, 2017 at 12:58:51PM -0700, Greg Kroah-Hartman wrote:
> > This adds a new ATEN device id for a new pl2303-based device.
> > 
> > Reported-by: Peter Kuo <PeterKuo@xxxxxxxxxxx>
> > Cc: stable <stable@xxxxxxxxxxxxxxx>
> > Signed-off-by: Greg Kroah-Hartman <gregkh@xxxxxxxxxxxxxxxxxxx>
> > 
> > ---
> > 
> > Peter, can you test this patch and verify it works for you?  Is there a
> > better name I can give this device other than ATEN_PRODUCT_ID3?
> > 
> > Johan, any objection for me to take this through my tree once Peter
> > verifies it?
> 
> None at all. In fact, there seems to be a few more on the way in which
> it would be great if you could pick up directly while I'm on vacation.

Ok, will do.

> 
> > diff --git a/drivers/usb/serial/pl2303.c b/drivers/usb/serial/pl2303.c
> > index c9ebefd8f35f..4b124c645175 100644
> > --- a/drivers/usb/serial/pl2303.c
> > +++ b/drivers/usb/serial/pl2303.c
> > @@ -53,6 +53,8 @@ static const struct usb_device_id id_table[] = {
> >  	{ USB_DEVICE(ATEN_VENDOR_ID, ATEN_PRODUCT_ID),
> >  		.driver_info = PL2303_QUIRK_ENDPOINT_HACK },
> >  	{ USB_DEVICE(ATEN_VENDOR_ID, ATEN_PRODUCT_ID2) },
> > +	{ USB_DEVICE(ATEN_VENDOR_ID, ATEN_PRODUCT_ID3),
> > +		.driver_info = PL2303_QUIRK_ENDPOINT_HACK },
> >  	{ USB_DEVICE(ATEN_VENDOR_ID2, ATEN_PRODUCT_ID) },
> >  	{ USB_DEVICE(ELCOM_VENDOR_ID, ELCOM_PRODUCT_ID) },
> >  	{ USB_DEVICE(ELCOM_VENDOR_ID, ELCOM_PRODUCT_ID_UCSGT) },
> > diff --git a/drivers/usb/serial/pl2303.h b/drivers/usb/serial/pl2303.h
> > index 09d9be88209e..dc55e3f2343c 100644
> > --- a/drivers/usb/serial/pl2303.h
> > +++ b/drivers/usb/serial/pl2303.h
> > @@ -28,6 +28,7 @@
> >  #define ATEN_VENDOR_ID2		0x0547
> >  #define ATEN_PRODUCT_ID		0x2008
> >  #define ATEN_PRODUCT_ID2	0x2118
> > +#define ATEN_PRODUCT_ID3	0x2021
> 
> I try to keep the defines themselves sorted by numerical PID, even if in
> this case and with these generic names that may seem counterintuitive.

Ok, I'll switch this around, hopefully I can get a better "name" for
this from Peter.

thanks,

greg k-h
--
To unsubscribe from this list: send the line "unsubscribe linux-usb" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html



[Index of Archives]     [Linux Media]     [Linux Input]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]     [Old Linux USB Devel Archive]

  Powered by Linux