Re: [PATCH] smsc95xx: Add comments to the registers definition

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hi Martin

> @@ -2032,7 +2032,7 @@ static struct sk_buff *smsc95xx_tx_fixup(struct usbnet *dev,
>  	skb_push(skb, 4);
>  	tx_cmd_b = (u32)(skb->len - 4);
>  	if (csum)
> -		tx_cmd_b |= TX_CMD_B_CSUM_ENABLE;
> +		tx_cmd_b |= TX_CMD_B_CSUM_EN;

This changed seems a step backwards, ENABLE is much more readable than EN.

>  
> -#define TX_CMD_B_CSUM_ENABLE		(0x00004000)
> -#define TX_CMD_B_ADD_CRC_DISABLE_	(0x00002000)
> -#define TX_CMD_B_DISABLE_PADDING_	(0x00001000)
> -#define TX_CMD_B_PKT_BYTE_LENGTH_	(0x000007FF)
> +#define TX_CMD_B_CSUM_EN	(0x00004000)	/* TX Checksum Enable */

And there is space for ABLE here.

    Andrew
--
To unsubscribe from this list: send the line "unsubscribe linux-usb" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html



[Index of Archives]     [Linux Media]     [Linux Input]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]     [Old Linux USB Devel Archive]

  Powered by Linux