The functions with name hibernation are misnamed originally. They were only responsible for partial power down and not for hibernation. This patch set adds the real hibernation support for dwc2 driver and renames existing functions to power_down.xisting functions to power_down. Changes in v2: -remove "usb: dwc2: Replace msleep with mdelay in dwc2_clear_force_mode()" from this series because it is unnescessary after force mode optimizations. John Youn (1): usb: dwc2: Enable power down Vardan Mikayelyan (13): usb: dwc2: Rename hibernation to partial_power_down usb: dwc2: Add hibernation field into dwc2_hw_params usb: dwc2: gadget: Moved dtxfsiz backup array place usb: dwc2: gadget: Fix dwc2_restore_device_registers usb: dwc2: core: Add hibernated flag usb: dwc2: gadget: Add remote_wakeup_allowed flag usb: dwc2: Changes in registers backup/restore functions usb: dwc2: Add helper functions for restore routine usb: dwc2: Add host/device hibernation functions usb: dwc2: Add dwc2_enter_hibernation(), dwc2_exit_hibernation() usb: dwc2: Allow entering hibernation from USB_SUSPEND interrupt usb: dwc2: Add dwc2_handle_gpwrdn_intr() handler usb: dwc2: Change hub-control to allow hibernation drivers/usb/dwc2/core.c | 210 +++++++++++++++++++++++++++++--- drivers/usb/dwc2/core.h | 68 +++++++++-- drivers/usb/dwc2/core_intr.c | 172 ++++++++++++++++++++++---- drivers/usb/dwc2/debugfs.c | 2 +- drivers/usb/dwc2/gadget.c | 226 +++++++++++++++++++++++++++++++++-- drivers/usb/dwc2/hcd.c | 279 ++++++++++++++++++++++++++++++++++++++++--- drivers/usb/dwc2/params.c | 50 +++++++- drivers/usb/dwc2/platform.c | 1 + 8 files changed, 921 insertions(+), 87 deletions(-) -- 1.9.1 -- To unsubscribe from this list: send the line "unsubscribe linux-usb" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html