On Fri, Sep 02, 2016 at 06:03:06PM -0700, Stephen Boyd wrote: > On Thu, Sep 1, 2016 at 8:17 PM, Peter Chen <hzpeterchen@xxxxxxxxx> wrote: > > On Wed, Aug 31, 2016 at 05:40:24PM -0700, Stephen Boyd wrote: > >> > >> > >> if (cable->state) > >> - val |= OTGSC_ID; > >> + val &= ~OTGSC_ID; /* A device */ > >> else > >> - val &= ~OTGSC_ID; > >> + val |= OTGSC_ID; /* B device */ One more comment, would you change the comment to "host" and "device"? Unless we are supporting OTG-compliance device, otherwise, we should not mention "A" or "B" for USB device. Peter > >> > >> if (cable->enabled) > >> val |= OTGSC_IDIE; > > > > /** > > * struct ci_hdrc_cable - structure for external connector cable state tracking > > * @state: current state of the line > > > > You may change the name of variable "state" to "connected", per I > > understand, it has changed to the meaning of connected status for your patch. > > > > Ok sure. -- Best Regards, Peter Chen -- To unsubscribe from this list: send the line "unsubscribe linux-usb" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html