Re: [PATCH 2/3] usb: gadget: use IS_ENABLED() instead of checking for built-in or module

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Javier Martinez Canillas <javier@xxxxxxxxxxxxxxx> writes:

> The IS_ENABLED() macro checks if a Kconfig symbol has been enabled either
> built-in or as a module, use that macro instead of open coding the same.
>
> Using the macro makes the code more readable by helping abstract away some
> of the Kconfig built-in and module enable details.
>
> Signed-off-by: Javier Martinez Canillas <javier@xxxxxxxxxxxxxxx>

Acked-by: Felipe Balbi <felipe.balbi@xxxxxxxxxxxxxxx>

> ---
>
>  drivers/usb/gadget/udc/omap_udc.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/usb/gadget/udc/omap_udc.c b/drivers/usb/gadget/udc/omap_udc.c
> index 9b7d39484ed3..a8709f9e5648 100644
> --- a/drivers/usb/gadget/udc/omap_udc.c
> +++ b/drivers/usb/gadget/udc/omap_udc.c
> @@ -2875,7 +2875,7 @@ bad_on_1710:
>  	xceiv = NULL;
>  	/* "udc" is now valid */
>  	pullup_disable(udc);
> -#if	defined(CONFIG_USB_OHCI_HCD) || defined(CONFIG_USB_OHCI_HCD_MODULE)
> +#if	IS_ENABLED(CONFIG_USB_OHCI_HCD)
>  	udc->gadget.is_otg = (config->otg != 0);
>  #endif
>  
> -- 
> 2.5.5
>
> --
> To unsubscribe from this list: send the line "unsubscribe linux-usb" in
> the body of a message to majordomo@xxxxxxxxxxxxxxx
> More majordomo info at  http://vger.kernel.org/majordomo-info.html

-- 
balbi

Attachment: signature.asc
Description: PGP signature


[Index of Archives]     [Linux Media]     [Linux Input]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]     [Old Linux USB Devel Archive]

  Powered by Linux