This 6-patch series gets rid of the pointless xhci_plat_type_is() in favour of a nicer setup where we initialize function pointers ahead of time using driver_data. That way we help the code look a little cleaner and easier to read. Felipe Balbi (6): usb: host: xhci: rcar: retire use of xhci_plat_type_is() usb: xhci: plat: add ->plat_start() and ->init_quirk() methods usb: host: xhci: plat: move mvebu init_quirk() to xhci_plat_setup() usb: host: xhci: plat: change type of mvebu init_quirk() usb: host: xhci: plat: make use of new methods in xhci_plat_priv usb: host: xhci: plat: finally get rid of xhci_plat_type_is() drivers/usb/host/xhci-mvebu.c | 7 ++++++- drivers/usb/host/xhci-mvebu.h | 7 +++++-- drivers/usb/host/xhci-plat.c | 46 +++++++++++++++++++++++++------------------ drivers/usb/host/xhci-plat.h | 20 ++----------------- drivers/usb/host/xhci-rcar.c | 13 +++++++++++- 5 files changed, 52 insertions(+), 41 deletions(-) -- 2.8.0.rc2 -- To unsubscribe from this list: send the line "unsubscribe linux-usb" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html