On Thu, Jan 14, 2016 at 05:37:15PM +0000, Martyn Welch wrote: > On 02/01/16 03:11, Konstantin Shkolnyy wrote: > > cp210x_get_config and cp210x_set_config are cumbersome to use. This change > > introduces new register access functions to replace them. New functions > > are not yet called - the switch is done gradually in following changes. > > > > Signed-off-by: Konstantin Shkolnyy <konstantin.shkolnyy-Re5JQEeQqe8AvxtiuMwx3w@xxxxxxxxxxxxxxxx> > > --- > > +/* > > + * Reads any 8-bit CP210X_ register identified by req. > > + */ > > +static int cp210x_read_u8_reg(struct usb_serial_port *port, u8 req, u8 *val) > > +{ > > + return cp210x_read_reg_block(port, req, val, sizeof(*val)); > > +} > > + > > +/* > > + * Writes any 16-bit CP210X_ register (req) whose value is passed > > + * entirely in the wValue field of the USB request. > > + */ > > +static int cp210x_write_u16_reg(struct usb_serial_port *port, u8 req, u16 val) > > Think this needs a different name to draw more attention to the fact > that it writes in a different way from cp210x_write_u32_reg and how the > cp210x_read_uXX_reg read. Not necessarily. Why would the caller need to care about that? Keeping the suggested names should be fine. Thanks, Johan -- To unsubscribe from this list: send the line "unsubscribe linux-usb" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html