On Wed, Nov 25, 2015 at 2:26 PM, Andy Shevchenko <andy.shevchenko@xxxxxxxxx> wrote: > On Wed, Nov 25, 2015 at 12:28 AM, Konstantin Shkolnyy > <konstantin.shkolnyy@xxxxxxxxx> wrote: >> +static bool cp210x_tx_empty(struct usb_serial_port *port) >> +{ >> + int err; >> + u32 count; >> + >> + err = cp210x_get_tx_queue_byte_count(port, &count); > >> + if (!err && count) >> + return false; >> + >> + return true; > > return err || !count; To me, expressing it like this is harder to read. The code as I wrote it, in my mind, reads like this: if successfully read the counter and it's not 0 then tx is not empty, return false > Btw, can be count left uninitialized? When the function succeeds it assigns a value to count. -- To unsubscribe from this list: send the line "unsubscribe linux-usb" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html