On Mon, Oct 12, 2015 at 08:31:55PM +0300, Sergei Shtylyov wrote: > Toshiba Portege 4000 quirk entry can be written shorter using the > PCI_DEVICE_SUB() macro. > > Signed-off-by: Sergei Shtylyov <sergei.shtylyov@xxxxxxxxxxxxxxxxxx> > > --- > The patch is against the 'usb-next' branch of Greg KH's 'usb.git' repo. > > drivers/usb/host/ohci-pci.c | 6 ++---- > 1 file changed, 2 insertions(+), 4 deletions(-) > > Index: usb/drivers/usb/host/ohci-pci.c > =================================================================== > --- usb.orig/drivers/usb/host/ohci-pci.c > +++ usb/drivers/usb/host/ohci-pci.c > @@ -192,10 +192,8 @@ static const struct pci_device_id ohci_p > }, > { > /* Toshiba portege 4000 */ > - .vendor = PCI_VENDOR_ID_AL, > - .device = 0x5237, > - .subvendor = PCI_VENDOR_ID_TOSHIBA, > - .subdevice = 0x0004, > + PCI_DEVICE_SUB(PCI_VENDOR_ID_AL, 0x5237, > + PCI_VENDOR_ID_TOSHIBA, 0x0004), But it's much less readable now, right? Why make this change then? sorry, greg k-h -- To unsubscribe from this list: send the line "unsubscribe linux-usb" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html