Re: [PATCH] usb: move assignment out of if condition

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hello.

On 6/30/2015 4:02 PM, Kris Borer wrote:

Fix four occurrences of the checkpatch.pl error:

ERROR: do not use assignment in if condition

Signed-off-by: Kris Borer <kborer@xxxxxxxxx>
---
  drivers/usb/core/hcd.c | 13 ++++++++-----
  1 file changed, 8 insertions(+), 5 deletions(-)

diff --git a/drivers/usb/core/hcd.c b/drivers/usb/core/hcd.c
index be5b207..e268c45 100644
--- a/drivers/usb/core/hcd.c
+++ b/drivers/usb/core/hcd.c
[...]
@@ -2734,7 +2735,8 @@ int usb_add_hcd(struct usb_hcd *hcd,
  	/* "reset" is misnamed; its role is now one-time init. the controller
  	 * should already have been reset (and boot firmware kicked off etc).
  	 */
-	if (hcd->driver->reset && (retval = hcd->driver->reset(hcd)) < 0) {
+	retval = hcd->driver->reset(hcd);
+	if (hcd->driver->reset && retval < 0) {

   If hcd->driver->reset() is NULL, this change warrants a kernel oops.

[...]

WBR, Sergei

--
To unsubscribe from this list: send the line "unsubscribe linux-usb" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html



[Index of Archives]     [Linux Media]     [Linux Input]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]     [Old Linux USB Devel Archive]

  Powered by Linux