Re: [PATCH] usb: isp1760: use msecs_to_jiffies for time conversion

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hi Nicholas,

Thank you for the patch.

On Friday 06 February 2015 05:08:53 Nicholas Mc Guire wrote:
> This is only an API consolidation and should make things more readable
> it replaces var * HZ / 1000 by msecs_to_jiffies(var).
> 
> Signed-off-by: Nicholas Mc Guire <hofrat@xxxxxxxxx>

Acked-by: Laurent Pinchart <laurent.pinchart@xxxxxxxxxxxxxxxx>

> ---
> 
> Patch was only compile tested with x86_64_defconfig + CONFIG_USB_ISP1760=m
> 
> Patch is against 3.19.0-rc7 (localversion-next is -next-20150204)
> 
>  drivers/usb/isp1760/isp1760-hcd.c |    6 +++---
>  1 file changed, 3 insertions(+), 3 deletions(-)
> 
> diff --git a/drivers/usb/isp1760/isp1760-hcd.c
> b/drivers/usb/isp1760/isp1760-hcd.c index eba9b82..3cb98b1 100644
> --- a/drivers/usb/isp1760/isp1760-hcd.c
> +++ b/drivers/usb/isp1760/isp1760-hcd.c
> @@ -1274,7 +1274,7 @@ static void errata2_function(unsigned long data)
>  	for (slot = 0; slot < 32; slot++)
>  		if (priv->atl_slots[slot].qh && time_after(jiffies,
>  					priv->atl_slots[slot].timestamp +
> -					SLOT_TIMEOUT * HZ / 1000)) {
> +					msecs_to_jiffies(SLOT_TIMEOUT))) {
>  			ptd_read(hcd->regs, ATL_PTD_OFFSET, slot, &ptd);
>  			if (!FROM_DW0_VALID(ptd.dw0) &&
>  					!FROM_DW3_ACTIVE(ptd.dw3))
> @@ -1286,7 +1286,7 @@ static void errata2_function(unsigned long data)
> 
>  	spin_unlock_irqrestore(&priv->lock, spinflags);
> 
> -	errata2_timer.expires = jiffies + SLOT_CHECK_PERIOD * HZ / 1000;
> +	errata2_timer.expires = jiffies + msecs_to_jiffies(SLOT_CHECK_PERIOD);
>  	add_timer(&errata2_timer);
>  }
> 
> @@ -1336,7 +1336,7 @@ static int isp1760_run(struct usb_hcd *hcd)
>  		return retval;
> 
>  	setup_timer(&errata2_timer, errata2_function, (unsigned long)hcd);
> -	errata2_timer.expires = jiffies + SLOT_CHECK_PERIOD * HZ / 1000;
> +	errata2_timer.expires = jiffies + msecs_to_jiffies(SLOT_CHECK_PERIOD);
>  	add_timer(&errata2_timer);
> 
>  	chipid = reg_read32(hcd->regs, HC_CHIP_ID_REG);

-- 
Regards,

Laurent Pinchart

--
To unsubscribe from this list: send the line "unsubscribe linux-usb" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html




[Index of Archives]     [Linux Media]     [Linux Input]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]     [Old Linux USB Devel Archive]

  Powered by Linux