Hello. On 2/8/2015 12:55 AM, Bas Peters wrote:
This patch removes assignment of variables in if conditions, as specified in CodingStyle.
Signed-off-by: Bas Peters <baspeters93@xxxxxxxxx> --- drivers/usb/core/hcd.c | 15 ++++++++++----- 1 file changed, 10 insertions(+), 5 deletions(-)
diff --git a/drivers/usb/core/hcd.c b/drivers/usb/core/hcd.c index 11cee55..37c40d1 100644 --- a/drivers/usb/core/hcd.c +++ b/drivers/usb/core/hcd.c
[...]
@@ -2733,7 +2736,8 @@ int usb_add_hcd(struct usb_hcd *hcd, /* "reset" is misnamed; its role is now one-time init. the controller * should already have been reset (and boot firmware kicked off etc). */ - if (hcd->driver->reset && (retval = hcd->driver->reset(hcd)) < 0) { + retval = hcd->driver->reset(hcd);
This will crash if 'hcd->driver->reset' is NULL (which is only checked below).
+ if (hcd->driver->reset && retval < 0) {
It wasn't equivalent change anyway as the right part of && is only executed if the left part is true.
WBR, Sergei -- To unsubscribe from this list: send the line "unsubscribe linux-usb" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html