Hello. On 2/6/2015 12:50 PM, Nicholas Mc Guire wrote:
This is only an API consolidation and should make things more readable it replaces var * HZ / 1000 by msecs_to_jiffies(var).
Signed-off-by: Nicholas Mc Guire <hofrat@xxxxxxxxx> ---
Note that the indentation is not aligned with the correct ( here due to lines going over 80 char - not sure if this is the right way to resolve this (this file has quite a few coding style issues).
Patch was only compile tested with x86_64_defconfig + CONFIG_USB_MDC800=m
Patch is against 3.19.0-rc7 (localversion-next is -next-20150204)
drivers/usb/image/mdc800.c | 11 +++++++---- 1 file changed, 7 insertions(+), 4 deletions(-)
diff --git a/drivers/usb/image/mdc800.c b/drivers/usb/image/mdc800.c index a62865a..3a72e8f 100644 --- a/drivers/usb/image/mdc800.c +++ b/drivers/usb/image/mdc800.c
[...]
@@ -743,8 +744,9 @@ static ssize_t mdc800_device_read (struct file *file, char __user *buf, size_t l mutex_unlock(&mdc800->io_lock); return len-left; } - wait_event_timeout(mdc800->download_wait, mdc800->downloaded, - TO_DOWNLOAD_GET_READY*HZ/1000); + wait_event_timeout(mdc800->download_wait, + mdc800->downloaded, + msecs_to_jiffies(TO_DOWNLOAD_GET_READY));
Don't indent with spaces (you're not aligning to open paren anyway), use the final tab instead, please.
WBR, Sergei -- To unsubscribe from this list: send the line "unsubscribe linux-usb" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html