From: Jingoo Han ... > /* The maximal threshold value is 0x80, which means 512 bytes */ > #define EHCI_THRESHOLD_512BYTES 0x80 > #define EHCI_THRESHOLD_508BYTES 0x79 It would be better to define these using expressions. So: #define EHCI_THRESHOLD_512BYTES (512u / 8u) #define EHCI_THRESHOLD_508BYTES (508u / 8u) Then you might decide to use: #define EHCI_THRESHOLD(size) ((size) / 8u) Then realise that the names are not generic EHCI, so need some driver-specific prefix (for namespace reasons). And that the defines are probably limit values, and should be named as such. David -- To unsubscribe from this list: send the line "unsubscribe linux-usb" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html