Re: [PATCH] usb: dwc3: Keeping 'resource' related code together

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hi,


On Wed, Jun 4, 2014 at 12:41 AM, Paul Zimmerman
<Paul.Zimmerman@xxxxxxxxxxxx> wrote:
>> From: linux-usb-owner@xxxxxxxxxxxxxxx [mailto:linux-usb-owner@xxxxxxxxxxxxxxx] On Behalf Of Vivek Gautam
>> Sent: Tuesday, June 03, 2014 3:40 AM
>>
>> Putting together the code related to getting the 'IORESOURCE_MEM'
>> and assigning the same to dwc->xhci_resources, for increasing
>> the readability.
>>
>> Signed-off-by: Vivek Gautam <gautam.vivek@xxxxxxxxxxx>
>> ---
>>
>> Based on 'next' branch of Felipe's usb tree.
>> Also cleanly applies to 'usb-next' branch of Greg's usb tree.
>>
>>  drivers/usb/dwc3/core.c |   38 +++++++++++++++++++-------------------
>>  1 file changed, 19 insertions(+), 19 deletions(-)
>>
>> diff --git a/drivers/usb/dwc3/core.c b/drivers/usb/dwc3/core.c
>> index 3f59c12..4ca925d 100644
>> --- a/drivers/usb/dwc3/core.c
>> +++ b/drivers/usb/dwc3/core.c
>> @@ -656,6 +656,25 @@ static int dwc3_probe(struct platform_device *pdev)
>>               return -ENODEV;
>>       }
>>
>> +     dwc->xhci_resources[0].start = res->start;
>> +     dwc->xhci_resources[0].end = dwc->xhci_resources[0].start +
>> +                                     DWC3_XHCI_REGS_END;
>> +     dwc->xhci_resources[0].flags = res->flags;
>> +     dwc->xhci_resources[0].name = res->name;
>> +
>> +     res->start += DWC3_GLOBALS_REGS_START;
>> +
>> +     /*
>> +      * Request memory region but exclude xHCI regs,
>> +      * since it will be requested by the xhci-plat driver.
>> +      */
>> +     regs = devm_ioremap_resource(dev, res);
>> +     if (IS_ERR(regs))
>> +             return PTR_ERR(regs);
>> +
>> +     dwc->regs       = regs;
>> +     dwc->regs_size  = resource_size(res);
>> +
>>       if (node) {
>>               dwc->maximum_speed = of_usb_get_maximum_speed(node);
>
> I think this will break if the following dwc3_core_get_phy() call returns
> -EPROBE_DEFER. Since you have incremented res->start above, the next time
> this probe function is called, res->start will have the wrong value.
> Provided I'm reading the code correctly of course :)

True, my fault. This will surely throw an error in requesting memory
region the next time probe
is called.
Thanks for catching this.

>
> I think you could fix that by decrementing res->start back to its
> original value just after the call to resource_size() above.

Sure will put
        res->start -= DWC3_GLOBALS_REGS_START;
right after the call to resource_size() call.



-- 
Best Regards
Vivek Gautam
Samsung R&D Institute, Bangalore
India
--
To unsubscribe from this list: send the line "unsubscribe linux-usb" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html




[Index of Archives]     [Linux Media]     [Linux Input]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]     [Old Linux USB Devel Archive]

  Powered by Linux