Hi all, ... > > - } else { > > + } else if (skip) { > > tst_brk_(file, lineno, TBROK | TERRNO, > > "overlayfs mount failed"); > > } > The skip flag should be called strict, at least that is what we usually > name it, but that is very minor. > ... > > static struct tst_test test = { > > .test = do_test, > > .tcnt = ARRAY_SIZE(test_cases), > > + .test_variants = 2, > > .setup = do_setup, > > .cleanup = do_cleanup, > > .needs_root = 1, > > .mount_device = 1, > > - .mntpoint = MOUNT_PATH, > > + .mntpoint = OVL_BASE_MNTPOINT, > > .all_filesystems = 1, > > .tags = (const struct tst_tag[]) { > > {"linux-git", "c285a2f01d69"}, > The git hash for the regression test with variant=1 should have been > added here. > The rest looks good to me. With the two minor issues fixed: > Reviewed-by: Cyril Hrubis <chrubis@xxxxxxx> > @Peter Vorel Feel free to push the patch with the two fixes applied. Thanks for spotting both issues, fixed and merged. Kind regards, Petr