Re: [RFC][PATCH] linux/uuid.h: hoist uuid_is_null() helper from libnvdimm

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Wed, May 3, 2017 at 12:13 PM, Andy Shevchenko
<andriy.shevchenko@xxxxxxxxxxxxxxx> wrote:
> On Tue, 2017-05-02 at 23:19 +0300, Amir Goldstein wrote:
>> We need a helper for VFS to check if struct super_block field s_uuid
>> was filled by the filesystem, before consumers can use it.
>>
>> The libnvdimm code already has a private helper to check if uuid is
>> null
>> and the helper name is not using a private namespace prefix, which
>> prevents us from using the same helper name as a common function.
>>
>
> Hmm...
> Have you checked my branch here:
> https://bitbucket.org/andy-shev/linux/branch/topic%2Fuuid
> ?
>

Hi Andy,

No I have not seen your patches. When do you plan to post them?

> Probably not.
> I have number of patches to make UUID API used kernel wide.
>

That looks nice, but I see you did not get to converting many other
users that represent uuid as u8[16], like libnvdimm, bluetooth,
various filesystems and users of sb->s_uuid (IMA).

> ...including helpers for null UUID check:
> https://bitbucket.org/andy-shev/linux/commits/79029ebe2c32830f82effc0f0b
> 62cce2b6eb7fdb?at=topic/uuid
>

I wouldn't mind using is_null_uuid_le(sb->s_uuid) myself and that is how
I implemented the test in my current patch set, but I can hear the voices of
those saying that there should be a 'natural' helper uuid_is_null(u8 *) for the
users that represent uuid as u8[16] (i.e. filesystems and sb->s_uuid).

Also, I suggest naming your helpers uuid_{le|be}_is_null() to maintain
the uuid_* naming convention with other helpers you added to uuid.h.

Cheers,
Amir.
--
To unsubscribe from this list: send the line "unsubscribe linux-unionfs" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html



[Index of Archives]     [Linux Filesystems Devel]     [Linux NFS]     [Linux NILFS]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux