On Mon, 25 Nov 2024 11:50:16 +0000 Metin Kaya <metin.kaya@xxxxxxx> wrote: > >> @@ -199,8 +199,8 @@ static void agent_handle(int sd, int nr_cpus, int page_size, > >> if (ret < 0) > >> die("Failed to receive trace request"); > >> > > > >> - tsync_proto = tracecmd_tsync_get_proto(tsync_protos, get_clock(argc, argv), > >> - tsync_role); > >> + tsync_proto = tcmd_tsync_get_proto(tsync_protos, get_clock(argc, argv), > >> + tsync_role); > > > > I'm fine with this change in general, except for converting any function > > name that starts with "tracecmd_" that is in the tracecmd/ directory. Yes > > it's marked as hidden, but these are functions that are not quite ready to > > become API, but are planned to. > > > > I used this as a general notation. If it starts with "tracecmd_" and marked > > as __hidden, it means that it is still a WIP API. If it is marked with > > "trace_" it is just a direct hook between trace-cmd and the libraries. > > > > Care to send a v3? > > Will do, but there is no function starts with "tracecmd_" defined under > tracecmd/ directory. Should it be lib/trace-cmd/ instead? No function should be defined under the tracecmd directory. I'm talking about all functions used under the tracecmd directory. > IOW, I should *not* rename the functions below. Correct? > - tracecmd_copy_trace_data() > - tracecmd_filter_free() > - tracecmd_filter_get() > - tracecmd_filter_match() > - tracecmd_filter_set() > - tracecmd_tsync_get_proto() I think the only one of the above is tracecmd_tsync_get_proto(). -- Steve