RE: [RFC PATCH 1/1] kernel-shark: Add plugin for handling Xenomai cobalt_context_switch

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



>
>
>On 16.12.21 ?. 4:16 ?., Hongzhan Chen wrote:
>> For Xenomai-cobalt enabled system, cobalt_switch_context means
>> that there is context switch in companion core(realtime core),
>> which we may need to do special treatment and take correct action
>> as main kernel sched_switch to visualize out-of-band state of
>> realtime tasks running in cobalt core. To achive our target,
>> we implement following:
>> 
>>    1. store corresponding cobalt_switch_context events into
>>       container data.
>>    2. modify pid stored in entry to be equal to next_pid to
>>       show correct color in cpu bar when cobalt_switch_context
>>       event happen.
>>    3. show blue hollow box to mark out-of-band state underneath
>>       the baseline of task plots according to cobalt_switch_context
>>       events.
>>    4. clickable cobalt_switch_context plugin shapes.
>> 
>> Signed-off-by: Hongzhan Chen <hongzhan.chen@xxxxxxxxx>
>> 
>> diff --git a/src/libkshark-tepdata.c b/src/libkshark-tepdata.c
>> index 9740ed9..e933b39 100644
>> --- a/src/libkshark-tepdata.c
>> +++ b/src/libkshark-tepdata.c
>> @@ -1208,6 +1208,7 @@ static void kshark_tep_init_methods(struct kshark_generic_stream_interface *inte
>>   /** A list of built in default plugins for FTRACE (trace-cmd) data. */
>>   const char *tep_plugin_names[] = {
>>   	"sched_events",
>> +	"xenomai_cobalt_switch_events",
>>   	"missed_events",
>>   	"kvm_combo",
>>   };
>> diff --git a/src/plugins/CMakeLists.txt b/src/plugins/CMakeLists.txt
>> index 3e170fa..16f080b 100644
>> --- a/src/plugins/CMakeLists.txt
>> +++ b/src/plugins/CMakeLists.txt
>> @@ -44,6 +44,10 @@ if (Qt5Widgets_FOUND AND TT_FONT_FILE)
>>                        SOURCE sched_events.c SchedEvents.cpp)
>>       list(APPEND PLUGIN_LIST "sched_events")
>>   
>> +    BUILD_GUI_PLUGIN(NAME xenomai_cobalt_switch_events
>> +                     SOURCE xenomai_cobalt_switch_events.c CobaltSwitchEvents.cpp)
>> +    list(APPEND PLUGIN_LIST "xenomai_cobalt_switch_events")
>> +
>>       BUILD_GUI_PLUGIN(NAME event_field_plot
>>                        MOC EventFieldDialog.hpp
>>                        SOURCE event_field_plot.c EventFieldDialog.cpp EventFieldPlot.cpp)
>> diff --git a/src/plugins/CobaltSwitchEvents.cpp b/src/plugins/CobaltSwitchEvents.cpp
>> new file mode 100644
>> index 0000000..26a0bcb
>> --- /dev/null
>> +++ b/src/plugins/CobaltSwitchEvents.cpp
>> @@ -0,0 +1,204 @@
>> +// SPDX-License-Identifier: LGPL-2.1
>> +
>> +/*
>> + * Copyright (C) 2018 Intel Inc, Hongzhan Chen<hongzhan.chen@xxxxxxxxx>
>
>I guess you mean 2021
>
>> + */
>> +
>> +/**
>> + *  @file    CobaltSwitchEvents.cpp
>> + *  @brief   Defines a callback function for Xenomai Cobalt context switch
>> + *           events used to plot in blue the out-of-band state of the task
>> + */
>> +
>> +// C++
>> +#include <vector>
>> +
>> +// KernelShark
>> +#include "libkshark.h"
>> +#include "libkshark-plugin.h"
>> +#include "plugins/xenomai_cobalt_switch_events.h"
>> +#include "KsPlotTools.hpp"
>> +#include "KsPlugins.hpp"
>> +#include "KsMainWindow.hpp"
>> +
>> +using namespace KsPlot;
>> +
>> +static KsMainWindow *ks_ptr;
>> +
>> +/**
>> + * @brief Provide the plugin with a pointer to the KsMainWindow object (the GUI
>> + * itself) such that the plugin can manipulate the GUI.
>> + */
>> +__hidden void *plugin_cobalt_set_gui_ptr(void *gui_ptr)
>> +{
>> +	ks_ptr = static_cast<KsMainWindow *>(gui_ptr);
>> +	return nullptr;
>> +}
>> +
>> +/**
>> + * This class represents the graphical element visualizing out-of-band state
>> + * that the task is running on
>
>
>This class seems to be a twin of the class defined by the sched_events plugin. Why don't you make the two plugins use a 
>common definition of it. The code that is being used in multiple plugins is supposed to live in src/KsPlugins.hpp/cpp
>You can also think of renaming it to something more generic.
>
>> + */
>> +class CobaltOobBox : public Rectangle
>> +{
>> +	/** On double click do. */
>> +	void _doubleClick() const override
>> +	{
>> +		ks_ptr->markEntry(_data[1]->entry, DualMarkerState::B);
>> +		ks_ptr->markEntry(_data[0]->entry, DualMarkerState::A);
>> +	}
>> +
>> +public:
>> +	/** The trace record data that corresponds to this CobaltOobBox. */
>> +	std::vector<kshark_data_field_int64 *>	_data;
>> +
>> +	/**
>> +	 * @brief Distance between the click and the shape. Used to decide if
>> +	 *	  the double click action must be executed.
>> +	 *
>> +	 * @param x: X coordinate of the click.
>> +	 * @param y: Y coordinate of the click.
>> +	 *
>> +	 * @returns If the click is inside the box, the distance is zero.
>> +	 *	    Otherwise infinity.
>> +	 */
>> +	double distance(int x, int y) const override
>> +	{
>> +		if (x < pointX(0) || x > pointX(2))
>> +			return std::numeric_limits<double>::max();
>> +
>> +		if (y > pointY(0) || y < pointY(1))
>> +			return std::numeric_limits<double>::max();
>> +
>> +		return 0;
>> +	}
>> +};
>> +
>> +static PlotObject *makeShape(std::vector<const Graph *> graph,
>> +			     std::vector<int> bins,
>> +			     std::vector<kshark_data_field_int64 *> data,
>> +			     Color col, float size)
>> +{
>> +	CobaltOobBox *rec = new CobaltOobBox;
>> +	rec->_data = data;
>> +
>> +	Point p0 = graph[0]->bin(bins[0])._base;
>> +	Point p1 = graph[0]->bin(bins[1])._base;
>> +	int height = graph[0]->height() * .3;
>> +
>> +	rec->setFill(false);
>> +	rec->setPoint(0, p0.x() - 1, p0.y() + height);
>> +	rec->setPoint(1, p0.x() - 1, p0.y() + 1);
>> +
>> +	rec->setPoint(3, p1.x() - 1, p1.y() + height);
>> +	rec->setPoint(2, p1.x() - 1, p1.y() + 1);
>> +
>> +	rec->_size = size;
>> +	rec->_color = col;
>> +
>> +	return rec;
>> +};
>
>This function can go to src/KsPlugins.cpp as well.

I change a little bit about position of point in the implementation to visualize blue hollow box underneath of baseline,
which is different from original makeShape of sched_events plugin.

>
>> +
>> +/*
>> + * Ideally, the cobalt_switch_context has to be the last trace event recorded before
>> + * the task is preempted. Because of this, when the data is loaded (the first pass),
>> + * the "pid" field of the cobalt_switch_context entries gets edited by this plugin
>> + * to be equal to the "next pid" of the cobalt_switch_context event. However, in
>> + * reality the cobalt_switch_context event may be followed by some trailing events
>> + * from the same task (printk events for example). This has the effect of extending
>> + * the graph of the task outside of the actual duration of the task. The "second
>> + * pass" over the data is used to fix this problem. It takes advantage of the
>> + * "next" field of the entry (this field is set during the first pass) to search
>> + * for trailing events after the "cobalt_switch_context". In addition, when
>> + * we find that it try to switch in-band because next-pid is zero, we prefer to
>> + * skip this event because it try to leave oob not enterring.
>> + */
>> +static void secondPass(plugin_cobalt_context *plugin_ctx)
>> +{
>> +	kshark_data_container *cSS;
>> +	kshark_entry *e;
>> +	int pid_rec, switch_inband;
>> +
>> +	cSS = plugin_ctx->cs_data;
>> +	for (ssize_t i = 0; i < cSS->size; ++i) {
>> +		switch_inband = plugin_cobalt_check_switch_inband(
>> +				cSS->data[i]->field);
>> +		if (switch_inband)
>> +			continue;
>> +		pid_rec = plugin_cobalt_get_pid(cSS->data[i]->field);
>> +		e = cSS->data[i]->entry;
>> +		if (!e->next || e->pid == 0 ||
>> +		    e->event_id == e->next->event_id ||
>> +		    pid_rec != e->next->pid)
>> +			continue;
>> +
>> +		e = e->next;
>> +		/* Find the very last trailing event. */
>> +		for (; e->next; e = e->next) {
>> +			if (e->pid == plugin_cobalt_get_pid(
>> +						cSS->data[i]->field)) {
>> +				/*
>> +				 * Change the "pid" to be equal to the "next
>> +				 * pid" of the cobalt_switch_context event
>> +				 * and leave a sign that you edited this
>> +				 * entry.
>> +				 */
>> +				e->pid = cSS->data[i]->entry->pid;
>> +				e->visible &= ~KS_PLUGIN_UNTOUCHED_MASK;
>> +			}
>> +			/*  This is the last trailing event, we finish
>> +			 *  this round.
>> +			 */
>
>This comment seems to be relevant for the case when the condition of the if() is true.
>If this is the case, please move it below the if().
>
>> +			if (e->next->pid != plugin_cobalt_get_pid(
>> +						cSS->data[i]->field))
>> +				break;
>> +		}
>> +	}
>> +}
>
>I do not understand completely what you are doing in this second pass, but for the moment I will assume that you know 
>what you are doing.

In the second pass,  it would try to change pid of all trailing events to be equal to be next_pid to show same color with next_pid
both in cpu bar and corresponding task bar to avoid color back and forth change especially when such trailing events is more than
one(It is quite common that there is more than one such trailing events in out trace data)  but original secondpass in SchedSwitch
just can only handle final one trailing event and then break so I change it here.


>
>> +
>> +/**
>> + * @brief Plugin's draw function.
>> + *
>> + * @param argv_c: A C pointer to be converted to KsCppArgV (C++ struct).
>> + * @param sd: Data stream identifier.
>> + * @param pid: Process Id.
>> + * @param draw_action: Draw action identifier.
>> + */
>> +__hidden void plugin_cobalt_draw(kshark_cpp_argv *argv_c,
>> +			  int sd, int pid, int draw_action)
>> +{
>> +	plugin_cobalt_context *plugin_ctx;
>> +
>> +	if (!(draw_action & KSHARK_TASK_DRAW) || pid == 0)
>> +		return;
>> +
>> +	plugin_ctx = __get_context(sd);
>> +	if (!plugin_ctx)
>> +		return;
>> +
>> +	KsCppArgV *argvCpp = KS_ARGV_TO_CPP(argv_c);
>> +
>> +	if (!plugin_ctx->second_pass_done) {
>> +		/* The second pass is not done yet. */
>> +		secondPass(plugin_ctx);
>> +		plugin_ctx->second_pass_done = true;
>> +	}
>> +
>> +	IsApplicableFunc checkFieldCS = [=] (kshark_data_container *d,
>> +					     ssize_t i) {
>> +		return !(plugin_cobalt_check_switch_inband(d->data[i]->field)) &&
>> +			d->data[i]->entry->pid == pid;
>> +	};
>> +
>> +	IsApplicableFunc checkEntryPid = [=] (kshark_data_container *d,
>> +					      ssize_t i) {
>> +		return plugin_cobalt_get_pid(d->data[i]->field) == pid;
>> +	};
>> +
>> +	eventFieldIntervalPlot(argvCpp,
>> +			       plugin_ctx->cs_data, checkFieldCS,
>> +			       plugin_ctx->cs_data, checkEntryPid,
>> +			       makeShape,
>> +			       {0, 0, 255}, // Blue
>> +			       -1);         // Default size
>> +}
>> diff --git a/src/plugins/xenomai_cobalt_switch_events.c b/src/plugins/xenomai_cobalt_switch_events.c
>> new file mode 100644
>> index 0000000..51d5dab
>> --- /dev/null
>> +++ b/src/plugins/xenomai_cobalt_switch_events.c
>> @@ -0,0 +1,198 @@
>> +// SPDX-License-Identifier: LGPL-2.1
>> +
>> +/*
>> + * Copyright (C) 2021 Intel Inc, Hongzhan Chen <hongzhan.chen@xxxxxxxxx>
>> + */
>> +
>> +/**
>> + *  @file    xenomai_cobalt_switch_events.c
>> + *  @brief   handle xenomai cobalt switch context event
>> + */
>> +
>> +// C
>> +#include <stdlib.h>
>> +#include <stdio.h>
>> +
>> +// trace-cmd
>> +#include <trace-cmd.h>
>> +
>> +// KernelShark
>> +#include "plugins/xenomai_cobalt_switch_events.h"
>> +#include "libkshark-tepdata.h"
>> +
>> +/** Plugin context instance. */
>> +
>> +#define SWITCH_INBAND_SHIFT	((int) ((sizeof(ks_num_field_t) - 1) * 8))
>> +
>> +#define SWITCH_INBAND_MASK		(((ks_num_field_t) 1 << 8) - 1)
>> +
>> +#define PID_MASK	(((ks_num_field_t) 1 << SWITCH_INBAND_SHIFT) - 1)
>> +
>> +//! @endcond
>
>'@endcond' is supposed to close a section that starts with '@cond Doxygen_Suppress'
>This tells Doxygen to ignore all definitions between the two. This is being used with some definitions that do not 
>require documentation.
>
>> +
>> +static void plugin_cobalt_set_pid(ks_num_field_t *field,
>> +				 unsigned long long pid)
>> +{
>> +	*field &= ~PID_MASK;
>> +	*field = pid & PID_MASK;
>> +}
>
>Again, this function and a lot of the code below are identical with the code in the sched_events plugin.
>Think for a way to get the two plugins use common definitions. Avoiding duplicated code will be beneficial even if you 
>decide to maintain the plugin in its own repo.
>
>Looking forward to see version 2.

Thanks for your time to review it and point them out. I would refine it.

Regards

Hongzhan Chen
>
>Thanks!
>Yordan
>
>




[Index of Archives]     [Linux USB Development]     [Linux USB Development]     [Linux Audio Users]     [Yosemite Hiking]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux