[PATCH] kernelshark: Rename tracefs_get_tracing_dir() to the new tracefs_tracing_dir()

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



From: "Steven Rostedt (VMware)" <rostedt@xxxxxxxxxxx>

libtracefs is renaming tracefs_get_tracing_dir() to tracefs_tracing_dir() as
there is no "tracefs_put_tracing_dir()" for this function. Since libtracefs
has not been officially released, it is fine to break API, as it is with
kernelshark v2.0 has not yet been official released that uses the old API.

Signen-off-by: Steven Rostedt (VMware) <rostedt@xxxxxxxxxxx>
---
 src/KsCaptureDialog.cpp | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/src/KsCaptureDialog.cpp b/src/KsCaptureDialog.cpp
index 63fd5d6..7253ab6 100644
--- a/src/KsCaptureDialog.cpp
+++ b/src/KsCaptureDialog.cpp
@@ -26,7 +26,7 @@ extern "C" {
 
 static inline tep_handle *local_events()
 {
-	return tracefs_local_events(tracefs_get_tracing_dir());
+	return tracefs_local_events(tracefs_tracing_dir());
 }
 
 /**
@@ -204,7 +204,7 @@ QStringList KsCaptureControl::_getPlugins()
 	QStringList pluginList;
 	char **all_plugins;
 
-	all_plugins = tracefs_tracers(tracefs_get_tracing_dir());
+	all_plugins = tracefs_tracers(tracefs_tracing_dir());
 
 	if (!all_plugins)
 		return pluginList;
-- 
2.25.4




[Index of Archives]     [Linux USB Development]     [Linux USB Development]     [Linux Audio Users]     [Yosemite Hiking]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux