On Fri, 17 Jul 2020 11:03:25 +0300 "Tzvetomir Stoyanov (VMware)" <tz.stoyanov@xxxxxxxxx> wrote: > The logic for finding all configured ftrace instances is encapuslated in > the new tracefs_instances_walk() API. A user specified callback is > called for each ftrace instance in the system, excpet for the top level > one. > The implementation of "trace-cmd stat" is modified to use the new API. > > Signed-off-by: Tzvetomir Stoyanov (VMware) <tz.stoyanov@xxxxxxxxx> > --- > include/tracefs/tracefs.h | 1 + > lib/tracefs/include/tracefs-local.h | 1 + > lib/tracefs/tracefs-events.c | 14 ++++---- > lib/tracefs/tracefs-instance.c | 52 +++++++++++++++++++++++++++++ > tracecmd/trace-stat.c | 52 ++++++++--------------------- > 5 files changed, 74 insertions(+), 46 deletions(-) > > diff --git a/include/tracefs/tracefs.h b/include/tracefs/tracefs.h > index 8ee7ba6e..0dd8046f 100644 > --- a/include/tracefs/tracefs.h > +++ b/include/tracefs/tracefs.h > @@ -32,6 +32,7 @@ int tracefs_instance_file_write(struct tracefs_instance *instance, > const char *file, const char *str); > char *tracefs_instance_file_read(struct tracefs_instance *instance, > char *file, int *psize); > +int tracefs_instances_walk(int (*callback)(const char *, void *), void *context); Perhaps a better name would be: tracefs_instance_iterate()? I usually consider a "walk" as going through a tree, not a list. If this was a directory tree, then "walk" would be more appropriate. An "iterator" is something that walks through a list and triggers a callback, like this does. But other than that, the patch looks good. -- Steve > > bool tracefs_file_exists(struct tracefs_instance *instance, char *name); > bool tracefs_dir_exists(struct tracefs_instance *instance, char *name); > diff --git a/lib/tracefs/include/tracefs-local.h b/lib/tracefs/include/tracefs-local.h > index fe327a0f..08b67fa9 100644 > --- a/lib/tracefs/include/tracefs-local.h >