The following commit has been merged into the sched/core branch of tip: Commit-ID: 77eccd0dfae353a64a2088d308bed3b373a4220f Gitweb: https://git.kernel.org/tip/77eccd0dfae353a64a2088d308bed3b373a4220f Author: Julian Wiedmann <jwi@xxxxxxxxxxxxx> AuthorDate: Tue, 01 Jun 2021 17:11:20 +02:00 Committer: Peter Zijlstra <peterz@xxxxxxxxxxxxx> CommitterDate: Mon, 28 Jun 2021 15:42:25 +02:00 wait: use LIST_HEAD_INIT() to initialize wait_queue_head Replace the open-coded initialization with the right macro. Signed-off-by: Julian Wiedmann <jwi@xxxxxxxxxxxxx> Signed-off-by: Peter Zijlstra (Intel) <peterz@xxxxxxxxxxxxx> Link: https://lkml.kernel.org/r/20210601151120.329223-1-jwi@xxxxxxxxxxxxx --- include/linux/wait.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/include/linux/wait.h b/include/linux/wait.h index fe10e85..99c5f05 100644 --- a/include/linux/wait.h +++ b/include/linux/wait.h @@ -56,7 +56,7 @@ struct task_struct; #define __WAIT_QUEUE_HEAD_INITIALIZER(name) { \ .lock = __SPIN_LOCK_UNLOCKED(name.lock), \ - .head = { &(name).head, &(name).head } } + .head = LIST_HEAD_INIT(name.head) } #define DECLARE_WAIT_QUEUE_HEAD(name) \ struct wait_queue_head name = __WAIT_QUEUE_HEAD_INITIALIZER(name)