* Brian Gerst <brgerst@xxxxxxxxx> wrote: > On Mon, Jun 8, 2015 at 3:25 PM, Ingo Molnar <mingo@xxxxxxxxxx> wrote: > > > > * Brian Gerst <brgerst@xxxxxxxxx> wrote: > > > >> > diff --git a/arch/x86/entry/syscall_32.c b/arch/x86/entry/syscall_32.c > >> > index 3777189..e398d03 100644 > >> > --- a/arch/x86/entry/syscall_32.c > >> > +++ b/arch/x86/entry/syscall_32.c > >> > @@ -10,7 +10,7 @@ > >> > #else > >> > #define SYM(sym, compat) sym > >> > #define ia32_sys_call_table sys_call_table > >> > -#define __NR_ia32_syscall_max __NR_syscall_max > >> > +#define __NR_entry_INT80_compat_max __NR_syscall_max > >> > #endif > >> > >> This change doesn't look intended. __NR_ia32_syscall_max is used by > >> all compat entry points, not just INT80, > > > > Indeed! > > > > How about the patch below? > > > > Thanks, > > > > Ingo > > > > ================> > > From 42b9d9a463bfb7252ede4eac24e50a4f013c6717 Mon Sep 17 00:00:00 2001 > > From: Ingo Molnar <mingo@xxxxxxxxxx> > > Date: Mon, 8 Jun 2015 21:20:26 +0200 > > Subject: [PATCH] x86/asm/entry: (Re-)rename __NR_entry_INT80_compat_max to __NR_syscall_compat_max > > > > Brian Gerst noticed that I did a weird rename in the following commit: > > > > b2502b418e63 ("x86/asm/entry: Untangle 'system_call' into two entry points: entry_SYSCALL_64 and entry_INT80_32") > > > > which renamed __NR_ia32_syscall_max to __NR_entry_INT80_compat_max. > > > > Now the original name was a misnomer, but the new one is a misnomer as well, > > as all compat syscall ABIs (such as x32) share the system call table, not just > > INT80 based ones. > > Not quite true. X32 is really an extension of the 64-bit ABI to support the > ILP32 data model. It uses the 64-bit SYSCALL entry point and table, but with > different syscall numbers for the syscalls that need 32-bit pointer handling in > data structures. > > So, __NR_syscall_compat_max is only for the 32-bit ABI compat syscall entries > (int80, sysenter, and syscall from 32-bit mode), and not X32. Indeed, and I knew this... Fixed the brainfart in the changelog. Thanks, Ingo -- To unsubscribe from this list: send the line "unsubscribe linux-tip-commits" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html
![]() |