On Sun, Mar 29, 2015 at 9:08 AM, Ingo Molnar <mingo@xxxxxxxxxx> wrote: >> >> Would be still nice to have it as an add on patch, if you agree with >> >> my arguments. >> > >> > Given that there are only a very small number of callers left and >> > they're all Obviously Correct (tm), I'm not too worried about it. >> > Maybe if we kill off __copy_to_user, I'll be inspired to kill off >> > user_mode_ignore_vm86 as well :) >> >> >> I was looking at the code involving this function and it looks >> like a much better name for user_mode_ignore_vm86() would be >> user_mode_cs(). >> >> Every time we use it, we check vm8086 mode just before it: >> >> perf_event.c >> >> if (regs->flags & X86_VM_MASK) >> return 0x10 * regs->cs; >> >> if (user_mode_ignore_vm86(regs) && regs->cs != __USER_CS) >> return get_segment_base(regs->cs); >> >> >> traps.c (three similar instances): >> >> if (v8086_mode(regs)) { >> ... >> goto exit; >> } >> if (user_mode_ignore_vm86(regs))... >> >> >> "_ignore_vm86" part doesn't quite work as an explanation. >> user_mode_cs() would immediately tell me "do we have a user's cs?" > > So what the function name wanted to express is something like this: > > if (user_mode_vm86_mode_already_checked_so_this_is_marginally_faster_but_dont_use_it_otherwise_because_that_would_be_a_roothole()) > { > ... > } > > but that name was considered somewhat long. LOL :D Seriously, though. I do think that user_mode_cs(regs) is a good name. It's short. It describes what it in fact checks. "(is it) user mode cs" reads as a valid English phrase, whereas "(is it) user mode ignore vm86" does not. -- To unsubscribe from this list: send the line "unsubscribe linux-tip-commits" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html
![]() |