* Joe Perches <joe@xxxxxxxxxxx> wrote: > On Fri, 2011-02-18 at 21:05 +0100, Ingo Molnar wrote: > > * Joe Perches <joe@xxxxxxxxxxx> wrote: > > > Ingo, why did you choose to apply this patch instead of > > > the alternative one I posted on the same thread? > > Your version: > > > > /* Board Name is optional */ > > board = dmi_get_system_info(DMI_BOARD_NAME); > > if (!board) > > board = ""; > > > > printk(KERN_CONT "\n"); > > > > printk(KERN_DEFAULT "Pid: %d, comm: %.20s %s %s %.*s %s %s%s%s\n", > > current->pid, current->comm, print_tainted(), > > init_utsname()->release, > > (int)strcspn(init_utsname()->version, " "), > > init_utsname()->version, > > vendor, product, > > strlen(board) ? "/" : "", > > board); > > > > The 'board' fiddling and the strlen(board) check complicates things unnecessarily > > and makes the code hard to read. Jan's version was at least simple. > > Perhaps you should look at the surrounding code. > It's uses the same style as I chose for "board". Yes, i realize that, but the strlen() trick really looks weird. And 'weird' is not something i like seeing in essential bug reporting code. Thanks, Ingo -- To unsubscribe from this list: send the line "unsubscribe linux-tip-commits" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html
![]() |