On Mon, Jan 31, 2011 at 7:53 AM, Tejun Heo <tj@xxxxxxxxxx> wrote: > Hello, Yinghai. > > On Fri, Jan 28, 2011 at 12:33:00PM -0800, Yinghai Lu wrote: >> > +#ifdef CONFIG_NUMA >> > +extern int __cpuinit numa_cpu_node(int apicid); >> >> cpu or apicid? > > Should have been @cpu. Will send a patch to update it. > >> > +int __cpuinit numa_cpu_node(int cpu) >> > +{ >> > + int apicid = early_per_cpu(x86_cpu_to_apicid, cpu); >> > + >> > + if (apicid != BAD_APICID) >> > + return __apicid_to_node[apicid]; >> > + return NUMA_NO_NODE; >> > +} >> >> it should be changed to cpu_to_node_via_apicid(), it could return >> not onlined node, aka node without memory. >> >> So don't mess it up with cpu_to_node() > > Hmmm... are you saying that the name is too confusing with > cpu_to_node() and should be renamed to cpu_to_node_via_apicid()? In > that case, I agree but wish the name were something which represents > what it does as _via_apicid postfix doesn't really tell much. Any > better idea? yes. wonder if there is other good name better than cpu_to_node_via_apicid... Yinghai -- To unsubscribe from this list: send the line "unsubscribe linux-tip-commits" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html
![]() |