Hi Laurent, On Fri, 8 Dec 2023 20:16:42 +0200 Laurent Pinchart <laurent.pinchart@xxxxxxxxxxxxxxxx> wrote: > The subdev .[gs]_frame_interval are video operations, but they operate > on pads (and even on streams). Not only is this confusing, it causes > practical issues for drivers as the operations don't receive a subdev > state pointer, requiring manual state handling. > > To improve the situation, turn the operations into pad operations, and > extend them to receive a state pointer like other pad operations. > > While at it, rename the operations to .[gs]et_frame_interval at the same > time to match the naming scheme of other pad operations. This isn't > strictly necessary, but given that all drivers using those operations > need to be modified, handling the rename separately would generate more > churn for very little gain (if at all). > > Signed-off-by: Laurent Pinchart <laurent.pinchart@xxxxxxxxxxxxxxxx> > Reviewed-by: Hans Verkuil <hverkuil-cisco@xxxxxxxxx> > Reviewed-by: Philipp Zabel <p.zabel@xxxxxxxxxxxxxx> # for imx-media ... > drivers/media/v4l2-core/v4l2-common.c | 8 +-- > drivers/media/v4l2-core/v4l2-subdev.c | 63 +++++++++++-------- ... > drivers/staging/media/tegra-video/csi.c | 9 +-- > include/media/v4l2-common.h | 4 +- > include/media/v4l2-subdev.h | 22 ++++--- For tegra-video: Reviewed-by: Luca Ceresoli <luca.ceresoli@xxxxxxxxxxx> I'm afraid I cannot test it as the tegra-video hardware I have has a parallel camera only, no CSI. Luca -- Luca Ceresoli, Bootlin Embedded Linux and Kernel engineering https://bootlin.com