On Thu, Oct 07, 2021 at 06:50:52PM +0200, Thierry Reding wrote: > > static const struct tegra_smmu_group_soc * > > -tegra_smmu_find_group(struct tegra_smmu *smmu, unsigned int swgroup) > > +tegra_smmu_find_group_soc(struct tegra_smmu *smmu, unsigned int swgroup) > > This one might be okay to disambiguate, but even here I think this isn't > really necessary. It's already clear from the return value what's being > returned. The point here is to disambiguate "group", as there are quite a few places using the same naming for different structures. You may argue that it's clear by looking at the return value/type. But it is still hard to tell when reading the code of its caller, right? > > @@ -921,9 +922,9 @@ static struct iommu_group *tegra_smmu_device_group(struct device *dev) > > } > > > > INIT_LIST_HEAD(&group->list); > > + group->group_soc = group_soc; > > group->swgroup = swgroup; > > group->smmu = smmu; > > - group->soc = soc; > > As another example, it's pretty evident that group->soc refers to the > group SoC data rather than the SMMU SoC data. The latter can be obtained > from group->smmu->soc, which again is enough context to make it clear > what this is. > > So I don't think this makes things any clearer. It only makes the names > more redundant and awkward to write. Okay. I will drop the part of s/soc/group_soc.