08.07.2020 11:44, Andy Shevchenko пишет: > On Wed, Jul 8, 2020 at 11:30 AM Dmitry Osipenko <digetx@xxxxxxxxx> wrote: >> >> There is no need to dedicate an array where a bitmap could be used. >> Let's replace the interrupt's enable-array with the enable-mask in order >> to improve the code a tad. > > ... > >> +#include <linux/bitops.h> > >> unsigned int irq_type[MAX77620_GPIO_NR]; >> - bool irq_enabled[MAX77620_GPIO_NR]; >> + unsigned long irq_enb_mask; > > I would rather to move to DECLARE_BITMAP() > (the macro is defined in types.h IIRC) > Hello, Andy! I know about DECLARE_BITMAP(), it is a very useful macro for bitmaps that are over 32 bits, which is absolutely not the case here. This macro will make code more difficult to read and then we will have to use the bitmap API, which is unnecessary overhead for this case, and thus, it won't be an improvement anymore, IMO. I'd either keep this patch as-is or drop it.