On 5/29/19 9:37 PM, Dmitry Osipenko wrote:
29.05.2019 11:21, Joseph Lo пишет:
This patch adds the required APIs and variables for the EMC scaling
sequence code on Tegra210.
Based on the work of Peter De Schrijver <pdeschrijver@xxxxxxxxxx>.
Signed-off-by: Joseph Lo <josephl@xxxxxxxxxx>
---
v4:
- fix the API with generic naming
- use 'u16' in 'struct emc_table_register_offset'
---
[snip]
+void emc_writel(struct tegra_emc *emc, u32 val, unsigned long offset)
+{
+ writel_relaxed(val, emc->emc_base[REG_EMC] + offset);
+}
+
u32 emc_readl(struct tegra_emc *emc, unsigned long offset)
{
return readl_relaxed(emc->emc_base[REG_EMC] + offset);
}
+u32 emc1_readl(struct tegra_emc *emc, unsigned long offset)
+{
+ return readl_relaxed(emc->emc_base[REG_EMC1] + offset);
+}
Please make all the global one-line functions static and inlined, then
move them out into the header. This will allow compiler to optimize code
better and also will hide these generic-looking global symbol names from
unrelated parties in the multiplatform kernel build.
Okay, will do.
Thanks,
Joseph