On Mon, Jan 18, 2016 at 06:03:57PM +0800, Wei Ni wrote: [...] > diff --git a/drivers/thermal/tegra/soctherm.c b/drivers/thermal/tegra/soctherm.c [...] > +static void soctherm_debug_init(struct platform_device *pdev) > +{ > + struct tegra_soctherm *tegra = platform_get_drvdata(pdev); > + struct dentry *root, *file; > + > + root = debugfs_create_dir("tegra_soctherm", NULL); Perhaps leave away the tegra_ prefix here? It's kind of redundant. > + if (!root) { > + dev_err(&pdev->dev, "failed to create debugfs directory\n"); > + return; > + } > + > + tegra->debugfs_dir = root; > + > + file = debugfs_create_file("regs", 0644, root, pdev, ®s_fops); Can we call this something different, please? "summary" would be a better name, in my opinion. > + if (!file) > + dev_err(&pdev->dev, "failed to create debugfs file\n"); > +} > +#else > +static inline void soctherm_debug_init(struct platform_device *pdev) > +{ return 0; } Please follow the regular CodingStyle here, too: ... { return 0; } > @@ -178,6 +309,10 @@ static int tegra_soctherm_probe(struct platform_device *pdev) > if (!tegra) > return -ENOMEM; > > + dev_set_drvdata(&pdev->dev, tegra); > + > + tegra->soc = soc; This looks odd here. Does this perhaps belong in one of the previous patches? Thierry
Attachment:
signature.asc
Description: PGP signature