Re: [PATCH v3 1/2] PCI: add helper function to find root port for device

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Am Freitag, den 23.01.2015, 16:34 -0600 schrieb Bjorn Helgaas:
> On Tue, Jan 13, 2015 at 08:57:27PM +0100, Lucas Stach wrote:
> > This adds a simple way to get the root port a given device
> > is connected to.
> > 
> > Signed-off-by: Lucas Stach <l.stach@xxxxxxxxxxxxxx>
> > ---
> > v2: new patch in v2
> > v3: rename to pci_find_rootport to fit better with other API
> > ---
> >  drivers/pci/search.c | 20 ++++++++++++++++++++
> >  include/linux/pci.h  |  1 +
> >  2 files changed, 21 insertions(+)
> > 
> > diff --git a/drivers/pci/search.c b/drivers/pci/search.c
> > index a20ce7d5e2a7..7254f126096d 100644
> > --- a/drivers/pci/search.c
> > +++ b/drivers/pci/search.c
> > @@ -384,3 +384,23 @@ int pci_dev_present(const struct pci_device_id *ids)
> >  	return 0;
> >  }
> >  EXPORT_SYMBOL(pci_dev_present);
> > +
> > +/**
> > + * pci_find_root_port - Returns the root port the given device is connected to.
> > + * @dev: PCI device for which the root port should be found.
> > + */
> > +struct pci_dev *pci_find_root_port(struct pci_dev *dev)
> 
> This seems a little too generic.  There are still PCI (non-PCIe) systems,
> and on those this will return some non-Root Port device, the meaning of
> which is unclear.  I'm happy to put something like this in pci-tegra.c, but
> until there are other potential users and we sort out the PCI/PCIe-ness of
> the interface, I don't really want to make it global and exported.
> 
I moved it out of the Tegra PCIe driver on your request. Also I can
already see this being useful for the Keystone PCI host driver to
shorten the MTRS quirk function.

I will rename this to pcie_find_root_port() so it is clear that this is
PCIe specific, but keep it in the current location.

> > +{
> > +	struct pci_bus *bus = dev->bus;
> > +
> > +	/* If there is no bridge on the bus the passed device is a root port. */
> 
> This assumption is false -- see the comment at pci_is_root_bus().
> 
Right, will change this.

Regards,
Lucas

-- 
Pengutronix e.K.             | Lucas Stach                 |
Industrial Linux Solutions   | http://www.pengutronix.de/  |

--
To unsubscribe from this list: send the line "unsubscribe linux-tegra" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html




[Index of Archives]     [ARM Kernel]     [Linux ARM]     [Linux ARM MSM]     [Linux USB Devel]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux