2015-01-20 Thierry Reding <thierry.reding@xxxxxxxxx>: > From: Thierry Reding <treding@xxxxxxxxxx> > > In order to prevent drivers from having to perform the same checks over > and over again, add an optional ->atomic_disable callback which the core > calls under the right circumstances. > > v2: pass old state and detect edges to avoid calling ->atomic_disable on > already disabled planes, remove redundant comment (Daniel Vetter) > > v3: rename helper to drm_atomic_plane_disabling() to clarify that it is > checking for transitions, move helper to drm_atomic_helper.h, clarify > check for !old_state and its relation to transitional helpers > > Signed-off-by: Thierry Reding <treding@xxxxxxxxxx> > --- > drivers/gpu/drm/drm_atomic_helper.c | 9 ++++++++- > drivers/gpu/drm/drm_plane_helper.c | 10 +++++++++- > include/drm/drm_atomic_helper.h | 37 +++++++++++++++++++++++++++++++++++++ > include/drm/drm_plane_helper.h | 3 +++ > 4 files changed, 57 insertions(+), 2 deletions(-) Reviewed-by: Gustavo Padovan <gustavo.padovan@xxxxxxxxxxxxxxx> Gustavo -- To unsubscribe from this list: send the line "unsubscribe linux-tegra" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html