Re: [PATCH V2 2/6] regulator: palmas: Rename reg_info to palmas_reg_info

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Mon, 30 Jun 2014, Nishanth Menon wrote:

> reg_info is a generic term which might cause conflict at a later point
> in time. To prevent such a thing from occuring in future, rename to
> palmas_reg_info.
> 
> Signed-off-by: Nishanth Menon <nm@xxxxxx>
> ---
>  drivers/regulator/palmas-regulator.c |    4 ++--
>  include/linux/mfd/palmas.h           |    4 ++--
>  2 files changed, 4 insertions(+), 4 deletions(-)

Acked-by: Lee Jones <lee.jones@xxxxxxxxxx>

> diff --git a/drivers/regulator/palmas-regulator.c b/drivers/regulator/palmas-regulator.c
> index 91f60fa..05f11b9 100644
> --- a/drivers/regulator/palmas-regulator.c
> +++ b/drivers/regulator/palmas-regulator.c
> @@ -41,7 +41,7 @@ static const struct regulator_linear_range smps_high_ranges[] = {
>  	REGULATOR_LINEAR_RANGE(3300000, 0x7A, 0x7f, 0),
>  };
>  
> -static struct regs_info palmas_regs_info[] = {
> +static struct palmas_regs_info palmas_regs_info[] = {
>  	{
>  		.name		= "SMPS12",
>  		.sname		= "smps1-in",
> @@ -227,7 +227,7 @@ static struct regs_info palmas_regs_info[] = {
>  	},
>  };
>  
> -static struct regs_info tps65917_regs_info[] = {
> +static struct palmas_regs_info tps65917_regs_info[] = {
>  	{
>  		.name		= "SMPS1",
>  		.sname		= "smps1-in",
> diff --git a/include/linux/mfd/palmas.h b/include/linux/mfd/palmas.h
> index 1a045ba..fb0390a 100644
> --- a/include/linux/mfd/palmas.h
> +++ b/include/linux/mfd/palmas.h
> @@ -102,7 +102,7 @@ struct palmas_sleep_requestor_info {
>  	int bit_pos;
>  };
>  
> -struct regs_info {
> +struct palmas_regs_info {
>  	char	*name;
>  	char	*sname;
>  	u8	vsel_addr;
> @@ -117,7 +117,7 @@ struct palmas_pmic_driver_data {
>  	int ldo_begin;
>  	int ldo_end;
>  	int max_reg;
> -	struct regs_info *palmas_regs_info;
> +	struct palmas_regs_info *palmas_regs_info;
>  	struct of_regulator_match *palmas_matches;
>  	struct palmas_sleep_requestor_info *sleep_req_info;
>  	int (*smps_register)(struct palmas_pmic *pmic,

-- 
Lee Jones
Linaro STMicroelectronics Landing Team Lead
Linaro.org │ Open source software for ARM SoCs
Follow Linaro: Facebook | Twitter | Blog
--
To unsubscribe from this list: send the line "unsubscribe linux-tegra" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html




[Index of Archives]     [ARM Kernel]     [Linux ARM]     [Linux ARM MSM]     [Linux USB Devel]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux