On 02/25/2014 05:22 AM, Heikki Krogerus wrote: > There is no use for them in this driver. This will fix a > static checker warning.. > > net/rfkill/rfkill-gpio.c:144 rfkill_gpio_probe() > warn: variable dereferenced before check 'rfkill->name' > > This will also make sure that when DT support is added, > "gpios" property can be used as no con_id labels are > provided. > diff --git a/net/rfkill/rfkill-gpio.c b/net/rfkill/rfkill-gpio.c > - gpio = devm_gpiod_get_index(&pdev->dev, rfkill->reset_name, 0); > + gpio = devm_gpiod_get_index(&pdev->dev, NULL, 0); I think the correct fix here is to look up the GPIO by name rather than by index, but simply hard-code the name rather than generating it with sprintf(). Index lookups are hard to expand compatibly, but named-based lookups scale much better. In other words, I rather specifically disagree with using a plain "gpios" property in any future DT binding, but would strongly prefer e.g. reset-gpios/shutdown-gpios or gpios/gpio-names. Still, I guess I don't object too much. -- To unsubscribe from this list: send the line "unsubscribe linux-tegra" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html