On Mon, Oct 14, 2024 at 01:29:07PM +0530, Rohit Chavan wrote: > This patch updates the GPIB driver code by replacing the use of kmalloc > followed by memset with kzalloc. This change simplifies the memory > allocation process by ensuring that the allocated memory is zero-initialized > in a single call, improving code readability and reducing the potential for > errors related to uninitialized memory. > > Signed-off-by: Rohit Chavan <roheetchavan@xxxxxxxxx> > --- > drivers/staging/gpib/agilent_82350b/agilent_82350b.c | 3 +-- > drivers/staging/gpib/cb7210/cb7210.c | 3 +-- > drivers/staging/gpib/gpio/gpib_bitbang.c | 3 +-- > drivers/staging/gpib/hp_82335/hp82335.c | 3 +-- > drivers/staging/gpib/hp_82341/hp_82341.c | 3 +-- > drivers/staging/gpib/ines/ines_gpib.c | 3 +-- > drivers/staging/gpib/tnt4882/tnt4882_gpib.c | 3 +-- > 7 files changed, 7 insertions(+), 14 deletions(-) You sent 2 patches that do almost the same thing, and have almost the same subject line, shouldn't they just be merged into 1 patch? Please do so and resend it as a v2. thanks, greg k-h