Re: [PATCH v2] staging: rtl8723bs: Improve clarity of MAR usage

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 7/31/24 10:15, Manjae Cho wrote:
This patch improves the readability of the code related to the Multicast
Address Register (REG_MAR) in the rtl8723bs driver. It adds comments to
clarify the purpose and offset of the register, making the code more
self-documenting without introducing new macros.

Signed-off-by: Manjae Cho <manjae.cho@xxxxxxxxxxx>
---

v2: Add comments for clarity instead of new macros

  drivers/staging/rtl8723bs/hal/sdio_halinit.c | 4 ++--
  1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/staging/rtl8723bs/hal/sdio_halinit.c b/drivers/staging/rtl8723bs/hal/sdio_halinit.c
index c9cd6578f7f8..535cd439121d 100644
--- a/drivers/staging/rtl8723bs/hal/sdio_halinit.c
+++ b/drivers/staging/rtl8723bs/hal/sdio_halinit.c
@@ -380,8 +380,8 @@ static void _InitWMACSetting(struct adapter *padapter)
  	rtw_write32(padapter, REG_RCR, pHalData->ReceiveConfig);
/* Accept all multicast address */
-	rtw_write32(padapter, REG_MAR, 0xFFFFFFFF);
-	rtw_write32(padapter, REG_MAR + 4, 0xFFFFFFFF);
+	rtw_write32(padapter, REG_MAR, 0xFFFFFFFF);	/* Offset 0x0620-0x0623 */
+	rtw_write32(padapter, REG_MAR + 4, 0xFFFFFFFF);	/* Offset 0x0624-0x0627 */
/* Accept all data frames */
  	value16 = 0xFFFF;

Hi Manjae,

may be this is version v2 of this patch with this subject. But the version is not about the subject. It is about the code change itself.

So I can see that this patch was send in with the following subjects:
[PATCH] Improve MAR register definition and usage for rtl8723
[PATCH v2] staging: rtl8723bs: Improve MAR register definition and usage
[PATCH] staging: rtl8723bs: Improve MAR register definition and usage
[PATCH v2] staging: rtl8723bs: Improve clarity of MAR usage

To me the last patch should be a v4. The next patch you send is the v5.
A change history is expected.

Description from Dan under:
https://staticthinking.wordpress.com/2022/07/27/how-to-send-a-v2-patch/

Thanks for your support.

Bye Philipp




[Index of Archives]     [Linux Driver Development]     [Linux Driver Backports]     [DMA Engine]     [Linux GPIO]     [Linux SPI]     [Video for Linux]     [Linux USB Devel]     [Linux Coverity]     [Linux Audio Users]     [Linux Kernel]     [Linux SCSI]     [Yosemite Backpacking]
  Powered by Linux