This patchset improves readability, maintainability & fixes 1 bug: - Rename device related vars. - Update pi433_receive param type. - Remove duplicated code in pi433_init. - Reorder pi433_exit calls. - Fix a potential debugfs resource leak. v2->v1: Followed by Dan Carpenter's <dan.carpenter@xxxxxxxxxx> comments: - Remove empty "fail" goto tag. - Reorder pi433 init & exit calls so they have reverse order. - Add "unreg_spi_drv" goto tag. - Check "debugfs_create_dir" return value. - Update "if" statements for consistency. - Rename pi433_init return var to the more common used "ret". v2->v3: Followed by more of Dan Carpenter's <dan.carpenter@xxxxxxxxxx> comments: - Undo pi433 init calls reordering. - Remove "unreg_spi_drv" tag. - Undo return value check for "debugfs_create_dir". - Undo "if" statements update. - Undo pi433_init return var renaming. - Split patch 5 into 3: duplicate code removal, bug fix, reorder exit calls. Shahar Avidar (7): staging: pi433: Rename struct pi433_device buffer field to tx_buffer. staging: pi433: Rename struct pi433_device instances to pi433. staging: pi433: Replace pi433_receive param void type to struct pi433_device. staging: pi433: Rename "pi433_dev" of type "dev_t" to "pi433_devt" staging: pi433: Remove duplicated code using the "goto" error recovery scheme. staging: pi433: Add debugfs_remove in case of driver register fails. staging: pi433: Reorder pi433_exit cleanup calls. drivers/staging/pi433/pi433_if.c | 690 +++++++++++++++---------------- 1 file changed, 345 insertions(+), 345 deletions(-) base-commit: a103e5ad21992384b0b4332df52e0467107eb113 prerequisite-patch-id: 91943193af2fea74182be67fb583235a3fbeb77b prerequisite-patch-id: 2cad031ba6a0782a67ab1645ff034a8be65c2e76 prerequisite-patch-id: 1a852ed8f9d133aec7c651fd9007e59e39c55fb7 -- 2.34.1