On Wed, Nov 01, 2023 at 06:21:34PM +0300, Dorcas AnonoLitunya wrote: > Modifies the return type of display_control_adjust_sm750le() > to void from unsigned long as the return value is being ignored in > all subsequent function calls. > > This improves code readability and maintainability. > > Suggested-by: Greg Kroah-Hartman <gregkh@xxxxxxxxxxxxxxxxxxx> > Signed-off-by: Dorcas AnonoLitunya <anonolitunya@xxxxxxxxx> > --- > > Changes in v3: > - Rebase patch to apply against latest branch > > drivers/staging/sm750fb/ddk750_mode.c | 4 +--- > 1 file changed, 1 insertion(+), 3 deletions(-) > > diff --git a/drivers/staging/sm750fb/ddk750_mode.c b/drivers/staging/sm750fb/ddk750_mode.c > index e1f20379431c..4278f9a826ab 100644 > --- a/drivers/staging/sm750fb/ddk750_mode.c > +++ b/drivers/staging/sm750fb/ddk750_mode.c > @@ -13,7 +13,7 @@ > * HW only supports 7 predefined pixel clocks, and clock select is > * in bit 29:27 of Display Control register. > */ > -static unsigned long > +static void > display_control_adjust_sm750le(struct mode_parameter *mode_param, > unsigned long disp_control) > { > @@ -70,8 +70,6 @@ display_control_adjust_sm750le(struct mode_parameter *mode_param, > disp_control |= DISPLAY_CTRL_CLOCK_PHASE; > > poke32(CRT_DISPLAY_CTRL, disp_control); > - > - return disp_control; > } > > /* only timing related registers will be programed */ > -- > 2.42.0.345.gaab89be2eb > > Does not apply to my current tree :(