On Tue, Oct 17, 2023 at 11:44:43AM +0300, Dorcas Litunya wrote: > On Tue, Oct 17, 2023 at 10:34:43AM +0200, Greg Kroah-Hartman wrote: > > On Tue, Oct 17, 2023 at 11:28:06AM +0300, Dorcas Litunya wrote: > > > On Tue, Oct 17, 2023 at 09:50:50AM +0200, Greg Kroah-Hartman wrote: > > > > On Mon, Oct 16, 2023 at 11:14:08PM +0300, Dorcas AnonoLitunya wrote: > > > > > Rename function displayControlAdjust_SM750E to > > > > > display_control_adjust_SM750E. This follows snakecase naming convention > > > > > and ensures a consistent naming style throughout the file. Issue found by > > > > > checkpatch. > > > > > > > > > > Mutes the following error: > > > > > CHECK:Avoid CamelCase: <displayControlAdjust_SM750E> > > > > > > > > > > Signed-off-by: Dorcas AnonoLitunya <anonolitunya@xxxxxxxxx> > > > > > --- > > > > > drivers/staging/sm750fb/ddk750_mode.c | 6 +++--- > > > > > 1 file changed, 3 insertions(+), 3 deletions(-) > > > > > > > > > > diff --git a/drivers/staging/sm750fb/ddk750_mode.c b/drivers/staging/sm750fb/ddk750_mode.c > > > > > index e00a6cb31947..8708995f676c 100644 > > > > > --- a/drivers/staging/sm750fb/ddk750_mode.c > > > > > +++ b/drivers/staging/sm750fb/ddk750_mode.c > > > > > @@ -14,8 +14,8 @@ > > > > > * in bit 29:27 of Display Control register. > > > > > */ > > > > > static unsigned long > > > > > -displayControlAdjust_SM750LE(struct mode_parameter *pModeParam, > > > > > - unsigned long dispControl) > > > > > +display_control_adjust_SM750LE(struct mode_parameter *pModeParam, > > > > > + unsigned long dispControl) > > > > > { > > > > > unsigned long x, y; > > > > > > > > > > @@ -125,7 +125,7 @@ static int programModeRegisters(struct mode_parameter *pModeParam, > > > > > tmp |= DISPLAY_CTRL_HSYNC_PHASE; > > > > > > > > > > if (sm750_get_chip_type() == SM750LE) { > > > > > - displayControlAdjust_SM750LE(pModeParam, tmp); > > > > > + display_control_adjust_SM750LE(pModeParam, tmp); > > > > > > > > Why is this function returning a value if it is just being ignored? > > > > > > > > It's not the issue here in the patch, but for future changes. > > > > > > > Hi Greg, > > > > > > I will do the correction in the next patchset to correct both functions > > > return value as this patchset was not focused on that. Does this mean > > > that this patchset has been accepted? Or should I submit another > > > patchset that includes the two changes suggested on function return > > > values? > > > > You'll get an email from my system when it is accepted, wait a day or so > > before worrying about that. And then send new patches on top of them > > then. > > > Thanks for the clarification Greg. I will wait for the confirmation > email from your system then send the new patches shortly afterwards. > > thanks, > Dorcas > > thanks, > > > > greg k-h Hello, I have realised there was an error in the commit message subject and body for this patch. I had put "Staging: sm750fb: Rename displayControlAdjust_SM750E" instead of "Staging: sm750fb: Rename displayControlAdjust_SM750LE".I had forgotten the L in SM750LE. I have modified the commit message using git commit --amend to correct the mistake. I have seen the patch has been accepted, however, I am not sure whether the change in the commit message will reflect once the patch is merged. Please guide on what to do next. I am really sorry for the inconvenience. Best, Dorcas